struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Venkatesh Nagarajan (JIRA)" <j...@apache.org>
Subject [jira] Commented: (STR-3182) Problem with web page navigation
Date Fri, 29 May 2009 04:58:42 GMT

    [ https://issues.apache.org/struts/browse/STR-3182?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=46247#action_46247
] 

Venkatesh Nagarajan commented on STR-3182:
------------------------------------------

Hi Paul,

Apologies for the delay in replying to you. We found the root cause of this issue. The issue
got resolved when an attribute was removed from a tag in the jsp file pertaining to the page
which was appearing blank. Certain attributes of tags are not compatible with Weblogic 10.
In other words, there was no issue with Struts navigation.

Please feel free to close this issue.

Thank you.

Regards,
Venkatesh

> Problem with web page navigation
> --------------------------------
>
>                 Key: STR-3182
>                 URL: https://issues.apache.org/struts/browse/STR-3182
>             Project: Struts 1
>          Issue Type: Bug
>    Affects Versions: 1.1.0
>         Environment: Unix (Sun Sparc), Weblogic 10.0
>            Reporter: Venkatesh Nagarajan
>
> Hi there,
> We have an enterprise application that uses Struts 1.1. It works fine in Weblogic 8.1
application server. When we deployed the application in Weblogic 10.0 application server,
we faced an issue with web page navigation. There are five web pages involved in a business
process. We are able to navigate through the first four web pages. But the navigation to the
fifth page probably fails. The fifth web page appears as a blank page which should not be
the case. I verified the contents of the ActionForward object that is retrieved using ActionMapping
class'  findForward(String) method in the Action class pertaining to the fourth page. It has
the right value for the path (URI). The following attributes seem to have correct values:
redirect=false and contextRelative=false.  It appears that Struts is unable to perform the
navigation to the fifth page. As I mentioned above, this problem does not happen when we deploy
the application in a Weblogic 8.1 application server.
> Could you please let me know your thoughts?
> Thank you.
> Regards,
> Venkatesh

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message