struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Maurizio Cucchiara (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (WW-3697) java.lang.NoClassDefFoundError since updated to 2.2.3.1 version struts2-core, xwork-core.
Date Thu, 03 Nov 2011 23:23:32 GMT

    [ https://issues.apache.org/jira/browse/WW-3697?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13143601#comment-13143601
] 

Maurizio Cucchiara commented on WW-3697:
----------------------------------------

Furthermore, when you will post on the user ML, consider that NoClassDefFoundError is not
enough, maybe it would be more useful to include the missing class name.
                
> java.lang.NoClassDefFoundError since updated to 2.2.3.1 version struts2-core, xwork-core.

> ------------------------------------------------------------------------------------------
>
>                 Key: WW-3697
>                 URL: https://issues.apache.org/jira/browse/WW-3697
>             Project: Struts 2
>          Issue Type: Bug
>          Components: Core Actions
>    Affects Versions: 2.2.3.1
>         Environment: Windows 7 32 bits, Eclipse Indigo 1.4.1 20110909-1818 (Eclipse Platform
3.7.1.M20110909-1335), Tomcat 7.0.22, java.runtime.name=Java(TM) SE Runtime Environment, java.runtime.version=1.6.0_20-b02,
java.vm.version=16.3-b01
>            Reporter: Carles Millan
>              Labels: issue, update
>             Fix For: 2.2.3
>
>
> Download the struts2 examples from http://code.google.com/p/struts2-examples/downloads/list.

> Example: http://code.google.com/p/struts2-examples/downloads/detail?name=Basic_Struts_2_Ant_2_2_1.zip
> If the jar included in the Eclipse lib are from version 2.2.1 the example runs well.

> Replace with the 2.2.3.1 versions: struts2-core-2.2.3.1.jar and xwork-core-2.2.3.1.jar
and run the example.
> The web page will report an "HTTP: 404 The requested resource (/Esborrar_02/) is not
available."
> Recover the 2.2.1 jar version an it's running propertly.
> I'm a newbie and maybe it's a configuration error, however replacing the libs it's enougth
to get the example running.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message