struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Loic VSCT (JIRA)" <j...@apache.org>
Subject [jira] [Created] (WW-3908) FreeMarker textfield tag doesn't allow the new HTML5 required attribute
Date Mon, 29 Oct 2012 12:42:11 GMT
Loic VSCT created WW-3908:
-----------------------------

             Summary: FreeMarker textfield tag doesn't allow the new HTML5 required attribute
                 Key: WW-3908
                 URL: https://issues.apache.org/jira/browse/WW-3908
             Project: Struts 2
          Issue Type: Bug
    Affects Versions: 2.3.6
         Environment: Windows 7 + JDK1.6.0_27 + Struts2 2.3.6 + FreeMarker 2.3.19
            Reporter: Loic VSCT


It is impossible to use the new HTML5 *required* attribute with the *textfield* tag currently
available in FreeMarker. Other HTML5 attributes seem to work as expected.

=> For example, I want to use the new *required* attribute in order to have the following
very simple HTML code :
{code:html}
<input type="text" required="required" id="test-X">
{code}

=> I have tried to use the following code in a classic FTL file :
{code:title=test.ftl|borderStyle=solid}
<@s.textfield required="required" id="test-1"/>
<@s.textfield required="true" id="test-2"/>
<@s.textfield required=required id="test-3"/>
<@s.textfield required=true id="test-4"/>
{code}

The HTML result is always :
{code:html}
<input type="text" id="test-X">
{code}


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message