struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rene Gielen (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (WW-4207) Upgrade to OGNL 3.0.8
Date Fri, 11 Apr 2014 13:35:20 GMT

    [ https://issues.apache.org/jira/browse/WW-4207?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13966483#comment-13966483
] 

Rene Gielen edited comment on WW-4207 at 4/11/14 1:35 PM:
----------------------------------------------------------

I make a case for upgrading to OGNL 3.0.9, for which I hope the following change will be applied
:)
- Upgrade javassist dependency to 3.1.18

The reason is that current version is not only incompatible with Hibernate 4, but also with
JDK8. Incompatibility with Hibernate 4 is due to the fact that javassisst groupId unfortunately
changed from javassist to org.javassist. Thus you get two javassist jar in your built artifact.
Currently, to incorporate Hibernate and other libraries introducing transitive dependencies
to newer javassist coordinates and versions, one has to exclude "old" dependency from struts-core:
{code:xml}
<dependency>
    <groupId>org.apache.struts</groupId>
    <artifactId>struts2-core</artifactId>
    <version>${struts2.version}</version>
    <exclusions>
        <exclusion>
            <groupId>javassist</groupId>
            <artifactId>javassist</artifactId>
        </exclusion>
    </exclusions>
</dependency>
{code}

Should I raise an issue for OGNL, and if yes, where?


was (Author: rgielen):
I make a case for upgrading to OGNL 3.0.9, for which I hope the following change will be applied
:)
- Upgrade javassist dependency to 3.1.18

The reason is that this version is not only compatible with Hibernate 4, but also with JDK8.
Incompatibility with Hibernate 4 is due to the fact that javassisst groupId unfortunately
changed from javassist to org.javassist. Thus you get two javassist jar in your built artifact.
Currently, to work with Hibernate and other tools introducing transiteve dependencies to newer
javassist coordinates and versions, one has to exclude "old" dependency from struts-core:
{code:xml}
<dependency>
    <groupId>org.apache.struts</groupId>
    <artifactId>struts2-core</artifactId>
    <version>${struts2.version}</version>
    <exclusions>
        <exclusion>
            <groupId>javassist</groupId>
            <artifactId>javassist</artifactId>
        </exclusion>
    </exclusions>
</dependency>
{code}

Should I raise an issue for OGNL, and if yes, where?

> Upgrade to OGNL 3.0.8
> ---------------------
>
>                 Key: WW-4207
>                 URL: https://issues.apache.org/jira/browse/WW-4207
>             Project: Struts 2
>          Issue Type: Improvement
>          Components: Value Stack
>    Affects Versions: 2.3.15
>            Reporter: Lukasz Lenart
>            Assignee: Lukasz Lenart
>             Fix For: 2.5
>
>




--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message