struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yasser Zamani (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (WW-4810) Calling empty locale
Date Wed, 05 Jul 2017 13:50:00 GMT

    [ https://issues.apache.org/jira/browse/WW-4810?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16074779#comment-16074779
] 

Yasser Zamani commented on WW-4810:
-----------------------------------

I could not re-produce. I tested `?request_locale=` , `?request_locale=''` and `?request_locale=""`.
All works redirecting to default locale with Struts 2.5.11. Same for `ff` , `fff` and `ffff`.
I did not get any exception.

> Calling empty locale
> --------------------
>
>                 Key: WW-4810
>                 URL: https://issues.apache.org/jira/browse/WW-4810
>             Project: Struts 2
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 2.5.11
>            Reporter: Markus Fischer
>            Priority: Minor
>             Fix For: 2.5.12
>
>
> < 2.5.11 calling empty locale {{?request_locale=}} results in locale {{en}}
> In 2.5.11 calling empty locale {{?request_locale=}} results in locale object (not null)
with property {{languageTag}} set to {{null}} and as {{language}} == {{empty}}
> NB: it is also interesting to see the different behaviours for
> {code}
> wget --header="Accept-Language: fff" --no-check-certificate https://localhost:8443/myProject/path
> {code}
> {code}
> "Accept-Language: ff" => Fula language
> "Accept-Language: fff" => empty locale
> "Accept-Language: ffff" => exception thrown
> {code}
> This seems to be the standard behaviour of Locale though.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message