struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig R. McClanahan" <Craig.McClana...@eng.sun.com>
Subject Re: Strut example broke on latest CVS version of tomcat?
Date Mon, 12 Jun 2000 18:48:21 GMT
"Hutchison, Jeff" wrote:

> I have the latest CVS build of tomcat and it appears that the struts
> example application stopped running normally after my latest update.
>

I just tried this and had different problems (it couldn't load the MessageTag class from
struts.jar).

Tomcat is going through some major rearrangements in the code right now, so it is very
likely to have various things broken until that is all shaken out.  I would suggest
sticking with Tomcat 3.1, or testing under Catalina -- for which you can get nightly
builds at:

    http://jakarta.apache.org/builds/catalina/nightly

Note there is a relevant bug in Catalina that will get fixed later today -- you need to
add a trailing slash to the URL you use to call the app:

    http://localhost:8080/struts-example/

instead of

    http://localhost:8080/struts-example

to make the relative page references work right.  I will fix this in tonight's nightly
build of Catalina.

Craig


>
> When I run the application just after starting tomcat, I get the
> following exception:
>
> javax.servlet.jsp.JspException: Missing resources attribute
> org.apache.struts.action.MESSAGE
>         at java.lang.Throwable.<init>(Throwable.java:96)
>         at java.lang.Exception.<init>(Exception.java:44)
>         at javax.servlet.jsp.JspException.<init>(JspException.java:73)
>         at
>   org.apache.struts.taglib.MessageTag.doStartTag(MessageTag.java:332)
>         at
>   _0002findex_0002ejspindex_jsp_1._jspService(_0002findex_0002ejspindex_jsp_1.java:68)
>         at
>   org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:126)
>         at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
> [snip]
>
> It appears that the action and database servlets are not being loaded at
> start up properly.  If I manually load both servlets by invoking them
> through my browser, then go to the struts example, all is fine.
>
> -jh
>
> --
> Jeff Hutchison <jhut@inst.strykercorp.com>
> Stryker Instruments Kalamazoo, MI


Mime
View raw message