struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig R. McClanahan" <Craig.McClana...@eng.sun.com>
Subject Re: example prevents Tomcat start throwingjava.lang.IllegalAccessError
Date Wed, 21 Jun 2000 17:41:26 GMT
Marius Sorin Barduta wrote:

> > Deep down, the IllegalAccessError problem with Tomcat 3.1 is actually
> caused by a
> > compiler bug, if you try to compile it (Tomcat) with a JDK 1.1 or 1.3
> compiler.
> > Be sure you are using the final binary release distribution.
>
> I'm sure I'm using the final binary release distribution
>
> > I have had IllegalAccessERror problems with Tomcat 3.1, especially when
> you try
> > to incorporate another XML parser (as Struts does, because it requires the
> > jaxp.jar and parser.jar files),
>
> Aren't jaxp.jar and parser.jar conflicting with xml.jar? I mean should I put
> jaxp.jar and parser.jar in lib under TOMCAT_CONF near xml.jar?
>

Yes, they "conflict" in the sense that they both have some classes with the same
names.  The JAXP parser happens to have the same name and behavior as the one in
xml.jar so it works with Tomcat 3.1.

Could you please do a "java -version" at the command line and report back what
it says?  (There might have been problems with early versions of 1.2.2 as well
-- I have to consult some notes to be sure).

>
> Thanks,
>
> Marius

Craig





Mime
View raw message