struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig R. McClanahan" <Craig.McClana...@eng.sun.com>
Subject Java2 Compatibility
Date Sat, 24 Jun 2000 20:28:44 GMT
Dear Struts Folk,

A couple of the new tags being added today require a Java2 platform (JDK
1.2 or later), because they utilize the new collection APIs.  This
raises the obvious question for the future -- is compatibility with JDK
1.1 important to Struts users?  Most of the application development
environments (and production sites) seem to be moving towards Java2 as a
minimum requirement.

Among other things, dropping JDK 1.1 compatibility would allow us to use
Java2 features inside of Struts as well.  Modest speed improvements (for
example) would be possible by using the collection classes -- you only
need to synchronize on things that can be changed, and are accessible
from multiple threads at the same time.

What do you think?  Please follow up on STRUTS-DEV only -- I cross
posted this message to keep users apprised of a potential major change.

Craig McClanahan



Mime
View raw message