struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Larry Rogers" <Larry_Rog...@mercmarine.com>
Subject Running Struts example
Date Tue, 04 Jul 2000 03:41:00 GMT


I've been following the discussion on both the user and dev lists, and I've read
all the fine documentation from Craig.  I'm excited to begin using the framework
for my apps!So, I'm trying to deploy the Struts framework on Apache with Tomcat
3.1 deployed with Apache on RedHat Linux 6.2 (I'm trying to transition from the
Windows world, too!).

I was able to start Tomcat and request static pages from Apache and to run all
the JSP and servlet samples that come with Tomcat.  I was also able to run the
struts-documentation application, all on port 8080.Then I installed the
struts-example app and I think that's when things fell apart.

Now when I try to start Tomcat, I get the following:

[rogersl@localhost bin]$ ./tomcat.sh
startException in thread "main" java.lang.NoClassDefFoundError:
org/apache/tomcat/shell/Startup
Guessing TOMCAT_HOME from tomcat.sh to ./..
Setting TOMCAT_HOME to ./..
Using classpath:
.:./../lib/ant.jar:./../lib/jasper.jar:./../lib/servlet.jar:./../lib/test:./../lib/webserver.jar:./../lib/xml.jar:/usr/local/jdk1.2.2/bin/../lib/tools.jar:/usr/local/jaxp1.0.1
[rogersl@localhost bin]$ Starting tomcat. Check logs/tomcat.log for error
messages
Exception in thread "main" java.lang.NoClassDefFoundError:
javax/xml/parsers/SAXParserFactory
     at
     at org.apache.struts.digester.Digester.parse(Digester.java:743)
     at org.apache.struts.example.DatabaseServlet.load(DatabaseServlet.java:282)
     at org.apache.struts.example.DatabaseServlet.init(DatabaseServlet.java:175)
     at javax.servlet.GenericServlet.init(GenericServlet.java:258)
     at
org.apache.tomcat.core.ServletWrapper.initServlet(ServletWrapper.java:315)
     at
org.apache.tomcat.core.ServletWrapper.loadServlet(ServletWrapper.java:276)
     at
org.apache.tomcat.context.LoadOnStartupInterceptor.contextInit(LoadOnStartupInterceptor.java:132)
     at
org.apache.tomcat.core.ContextManager.initContext(ContextManager.java:227)
     at org.apache.tomcat.core.ContextManager.init(ContextManager.java:201)
     at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:156)
     at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:163)

I can still request pages from Apache on port 80, but nothing from 8080.  As you
can see, webserver.jar is in the CLASSPATH, and I verified that the Startup
class is indeed in the jar file.

If anyone can suggest where to look next to get Struts working, I would
appreciate it.  Also, can you tell me why Tomcat is not starting correctly
anymore?

BTW, I had this all working great under WinNT Server 4, IIS 4 and JRun.

TIA,

Larry Rogers



Mime
View raw message