struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Baron" <ba...@i-hometown.com>
Subject May I ask a question of Tomcat?
Date Mon, 30 Oct 2000 12:32:40 GMT
Hi,

I was installing Tomcat and Apache for testing. Most of functions were working fine.
But there was a problem when I want to upload  a file. A form tag was setting in a jsp file
as following
<form enctype="multipart/form-data" action="/servlet/UploadDepartmentImage" method=POST>
when I submit to upload, the URL was transfered to
http://servername/servlet/UploadDepartmentImage , this is a worng URL
Actually, the correct URL should be 
http://servername/jeestore/servlet/jeestore/UploadDepartmentImage

And, web.xml was setting as following

<web-app>
    <servlet>
        <servlet-name>jeestore</servlet-name>
        <servlet-class>com.jeestore.JeestoreServlet</servlet-class>
           <init-param>
             <param-name>servlet.properties.location</param-name>
             <param-value>/home/jeestore/etc/jeestore.properties</param-value>
           </init-param>
        <load-on-startup>1</load-on-startup>
    </servlet>
    <servlet>
        <servlet-name>UploadLogo</servlet-name>
                <servlet-class>com.oreilly.servlet.UploadLogo</servlet-class>
                <load-on-startup>2</load-on-startup>
    </servlet>
    <servlet>
        <servlet-name>UploadProductImage</servlet-name>
                <servlet-class>com.oreilly.servlet.UploadProductImage</servlet-class>
                <load-on-startup>3</load-on-startup>
    </servlet>
    <servlet>
        <servlet-name>UploadDepartmentImage</servlet-name>
                <servlet-class>com.oreilly.servlet.UploadDepartmentImage</servlet-class>
                <load-on-startup>4</load-on-startup>
    </servlet>
</web-app>
 
Would you please tell me what's wrong? 
Thanks.
 
Baron


Mime
View raw message