struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aapo Laakkonen" <aapo.laakko...@projectcast.com>
Subject Re: Wrong ordering of rendered html elements when using templates under WAS 3.5.x
Date Wed, 01 Aug 2001 23:17:05 GMT
FW: Wrong ordering of rendered html elements when using templates under WAS 3.5.xI don't know
if this helps, but I use something like this:

<html:html locale="true">

    <template:insert template="templates/head.jsp">
        <template:put name="title" direct="true">
            <bean:message key="title.sometitle"/>
        </template:put>
    </template:insert>

    <template:insert template="templates/body_begin.jsp"/>

    <!-- PUT YOUR CONTENT HERE -->

    <template:insert template="templates/body_end.jsp"/>

</html:html>

  ----- Original Message ----- 
  From: Nik Malenovic 
  To: struts-user@jakarta.apache.org 
  Sent: Thursday, August 02, 2001 1:11 AM
  Subject: FW: Wrong ordering of rendered html elements when using templates under WAS 3.5.x


  Hello personable people, 

  We've got a live one over here - I've dug up an issue when using templates under WebSphere
3.5.4 (don't ask) with struts 1.0 (plus a fix or two that is required to get struts functioning
properly under WAS3.5.x). The issue is that my JSP produces misordered html snippets.



  Here's what I mean: 

  Actors: 
  ------- 
  Home.jsp 
  Home_content.jsp 
  Home_template.jsp 



  Home.jsp: 
  --------- 
  [<%@ taglibs here %> ] 
  <!-- home.jsp:My Title --> 
  <template:insert template="home_template.jsp"> 
    <template:put name="title" direct="true">My Title</template:put> 
    <template:put name="content" content="home_content.jsp" /> 
  </template:insert> 



  Home_content.jsp: 
  ------------------ 
  [<%@ taglibs here %> ] 
  <table width="100%" border="0" cellspacing="0" cellpadding="0"> 
    <tr> 
      <td>foo</td> 
    </tr> 
  </table> 



  Home_template.jsp 
  ------------------ 
  [<%@ taglibs here %> ] 
  <html:html locale="true"> 
    <head> 
      <title><template:get name="title" /> </title> 
    </head> 
    <body bgcolor="#FFFFFF" text="#000000" leftmargin="0" topmargin="0" marginwidth="0"
marginheight="0"> 
      <table width="100%" border="0" cellspacing="0" cellpadding="0" height="24"> 
        <tr> 
          SOME MORE WILD TEXT HERE 
        </tr> 
      </table> 
      <!-- begin content --> 
      <template:get name="content" /> 
      <!-- end content --> 
    </body> 
  </html:html> 




  Output of glorious home.jsp hosted by WAS3.5.x (notice out of order rendering!): 
  ----------------------------------------------------------------------------- 
  <table width="100%" border="0" cellspacing="0" cellpadding="0"> 
    <tr> 
      <td>foo</td> 
    </tr> 
  </table> 
  <html lang="en"> 
    <head> 
      <title> 
        My Title 
     </title> 
    </head> 
    <body bgcolor="#FFFFFF" text="#000000" leftmargin="0" topmargin="0" marginwidth="0"
marginheight="0"> 
      <table width="100%" border="0" cellspacing="0" cellpadding="0" height="24"> 
        <tr> 
          SOME MORE WILD TEXT HERE 
        </tr> 
      </table> 
      <!-- begin content --> 
      
      <!-- end content --> 
    </body> 
  </html> 





  <!-- home.jsp:My Title --> 




  See the problem? :-) I'd appreciate anyone with a clue to send me one. 



  Thanks, 



  Nik 
  -- 
  Nik Malenovic <mailto:nmalenovic@msn.com> 


Mime
View raw message