struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Quas <tq...@acm.org>
Subject Tomcat-4.0.1 & Struts-1.0 do *not* go together
Date Sat, 01 Dec 2001 17:49:55 GMT

Sorry if I'm not telling you news, but I thought it might be worthwhile 
mentioning.


This is the environment:

$ uname -a
Linux gollum.tquas.org 2.2.19 #4 Sun Nov 25 14:35:48 CET 2001 i686 unknown

$ java -version
java version "1.3.0"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.0)
Java HotSpot(TM) Client VM (build 1.3.0, interpreted mode)



I hacked a .jsp starting with the following lines:

<%@ page language="java" %>
<%@ page import="java.io.*, javax.servlet.jsp.PageContext" %>
<%@ taglib uri="/WEB-INF/struts-bean.tld" prefix="bean" %>
<%@ taglib uri="/WEB-INF/struts-html.tld" prefix="html" %>


and it would *crash* Tomcat causing it to dump core. When I switched 
back to Tomcat-4.0 it worked just fine.

I figured out that the two 'taglib' statements caused the problems, but 
don't ask me why that is. I attached the file in case somebody wants to 
investigate.



tom
-- 
thomas quas        | "Art lies in the consciousness of doing the thing,
tquas@acm.org      |  in the attention of the happening[...]"
                    |    -- Allen Ginsberg --


Mime
View raw message