struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Louis Leung <louis.le...@sun.com>
Subject Re: Character Encoding wrong just for ApplicationResources!
Date Wed, 13 Feb 2002 22:15:33 GMT
or you can covert your properties file strings from native to unicode using this
method

return new String(oldString.getBytes(), encoding);

where encoding is the native encoding u used in your properties file

more 'bout charset encoding/decoding on this page :

http://tagunov.newmail.ru/i18n/i18n.html

Hertzel Karbasi - OPTinity eBusiness Solutions wrote:

> Hello All
>
> I have added  the following to JSP files
> <META http-equiv="Content-Type" content="text/html, charset=UTF-8">
> <%@ page contentType="text/html; charset=UTF-8" %>
> <html:html locale="true">
> Change the locale in an Action to iw_IL
>
> And get:
> Constant strings inserted in JSP in Hebrew are OK.
> Just the Strings (<html:message> coming from Applicationresource are shown
> as "??"
> I have checked the messages in debug and found out that they come as "????"
> from the resource.
> The constant string inserted in the JSP in Hebrew just to check the browser
> and they have been displayed right!
>
> Any assistance will be appreciated.
> Thanks
> Hertzel
>
>   ------------------------------------------------------------------------
> --
> To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message