struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gao, Gang" <Gang....@ap.bdi.gte.com>
Subject IndexOutOfBoundsException and Error creating Action instance for path
Date Thu, 14 Feb 2002 22:35:19 GMT
Hi,
I have a problem for struts in my product server.The error message is
following:

<Feb 13, 2002 6:07:50 AM EST> <Info> <HTTP>
<[WebAppServletContext(5236534,ISPServiceCenter.war)] action: Processing a
GET for /intranet/workflow/coordinator> 
<Feb 13, 2002 6:07:50 AM EST> <Info> <HTTP>
<[WebAppServletContext(5236534,ISPServiceCenter.war)] action:  Looking for
ActionForm bean under attribute 'allTasksSearchForm'> 
<Feb 13, 2002 6:07:50 AM EST> <Info> <HTTP>
<[WebAppServletContext(5236534,ISPServiceCenter.war)] action:  Creating new
ActionForm instance of class
'com.verizon.ispcentral.icare.requestmgmt.struts.intranet.workflow.alltasks.
AllTasksSearchForm'> 
Search User .
<Feb 13, 2002 6:07:50 AM EST> <Info> <HTTP>
<[WebAppServletContext(5236534,ISPServiceCenter.war)] action:  Storing
instance under attribute 'allTasksSearchForm' in scope 'session'> 
<Feb 13, 2002 6:07:50 AM EST> <Info> <HTTP>
<[WebAppServletContext(5236534,ISPServiceCenter.war)] action:  Populating
bean properties from this request> 
<Feb 13, 2002 6:07:50 AM EST> <Info> <HTTP>
<[WebAppServletContext(5236534,ISPServiceCenter.war)] action:  Validating
input form properties> 
<Feb 13, 2002 6:07:50 AM EST> <Info> <HTTP>
<[WebAppServletContext(5236534,ISPServiceCenter.war)] action:   No errors
detected, accepting input> 
<Feb 13, 2002 6:07:50 AM EST> <Info> <HTTP>
<[WebAppServletContext(5236534,ISPServiceCenter.war)] action:  Looking for
Action instance for class
com.verizon.ispcentral.icare.requestmgmt.struts.intranet.workflow.alltasks.C
oordinatorAction> 
<Feb 13, 2002 6:07:50 AM EST> <Info> <HTTP>
<[WebAppServletContext(5236534,ISPServiceCenter.war)] action:   Double
checking for Action instance already there> 
<Feb 13, 2002 6:07:50 AM EST> <Info> <HTTP>
<[WebAppServletContext(5236534,ISPServiceCenter.war)] action:   Creating new
Action instance> 
<Feb 13, 2002 6:07:50 AM EST> <Error> <HTTP>
<[WebAppServletContext(5236534,ISPServiceCenter.war)] action: Error creating
Action instance for path '/intranet/workflow/coordinator', class name
'com.verizon.ispcentral.icare.requestmgmt.struts.intranet.workflow.alltasks.
CoordinatorAction'
java.lang.IndexOutOfBoundsException
	at
java.util.zip.InflaterInputStream.read(InflaterInputStream.java:121)
	at weblogic.utils.classloaders.ZipSource.getBytes(ZipSource.java:52)
	at
weblogic.utils.classloaders.GenericClassLoader.findLocalClass(GenericClassLo
ader.java:270)
	at
weblogic.utils.classloaders.GenericClassLoader.findClass(GenericClassLoader.
java:155)
	at
weblogic.utils.classloaders.ChangeAwareClassLoader.findClass(ChangeAwareClas
sLoader.java:45)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:297)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:253)
	at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:313)
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Class.java:120)
	at
org.apache.struts.action.ActionServlet.processActionCreate(ActionServlet.jav
a:1630)
	at
org.apache.struts.action.ActionServlet.process(ActionServlet.java:1576)
	at
org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:491)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
	at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java
:213)
	at
weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletCo
ntext.java:1265)
	at
weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java
:1631)
	at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:137)
	at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:120)
> 

>From this message, I can't find any problem related to my application
code(usually it should print out line #  refering to action class or jsp
page). So I guess maybe it is struts bug or something else. Please help me
out. This is from our production server,  any hint would be very helpful.

Gang Gao
Verizon e-biz


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message