struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jones, Richard" <Richard.Jo...@fiserv.com>
Subject RE: submitting with link
Date Thu, 01 Jan 1970 00:00:00 GMT
Hello,

I have a similar issue.  I have a logon form that is using links rather than 
buttons.  My form declaration is <html:form action="/logon.do">.  Currently, I 
have two html:link elements used to submit and reset the form.  The href 
attributes are "#".  I also invoke a javascript logonValidate script, which 
calls document.logonForm.submit() if validation passes.  This all works fine in 
the nominal case.

Now, the problem(s).  I am also using the checkLogon custom tag to "protect" 
pages, enforcing a user logon.  If the user attempts to access, say, a search 
page (search.jsp) while not logged on, the custom tag catches this and forwards 
back to the logon page.  Then, if the user credentials are then entered 
(correctly) and the form is submitted, the logon form is redisplayed and 
reset.  If the information is entered a second time and the form submitted, it 
works fine (takes me to the search page).  My config is set up with the logon 
action as session scoped (I started with it as request scoped).  I do not have 
a global forward set up for logon.  If I attempt to use the page attribute of 
html:link and set it to /logon.do, the reset problem goes away, but my form 
data is not posted properly.

Hope this is not too redundant.  Any help is appreciated.


Rich


--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message