struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "B.Adji Maharyatno" <a...@opentech.com.sg>
Subject RE: Struts with JBuilder6.0 and Tomcat
Date Mon, 29 Apr 2002 04:55:40 GMT
We have this issue from last year.
Borland has yet resolved this at JBuilder6 or BES.

You can try this solution (althought not ideal).

1. Delete struts-config_1_0.dtd from the struts.jar (can use winzip or other
tools).
2. Copy the struts-config_1_0.dtd file at your WebApplication folder (the
root).
3. Copy the struts-config_1_0.dtd at <JBuilder-Home>\bin (if you want to use
the XML validator).

Assume you create a web-application folder:
<project-home>\<web-application>
Copy the file as in this root.
---- <WEB-INF>

If your project is WebTest1 and your web-applicatino is also WebTest1,
normally you would have web-application folder as <...>\WebTest1\WebTest1.

However, I found that using JBuilder 5 and Borland AppServer 4.5 have no
issues on using Struts. Just deploy the .war file to Borland AppServer 4.5
(using the deploy tool).

Hope will help.

Cheers.
BAM



-----Original Message-----
From: Ketan Malekar [mailto:ketanmalekar@hotmail.com]
Sent: Saturday, May 29, 1999 11:22 PM
To: Struts Users Mailing List
Subject: Struts with JBuilder6.0 and Tomcat


hello friends,
Im using JBuilder 6.0 and have downloaded Struts Wizard for JBuilder6.0
(JBuilderStrutsWizard.jar). And included in the lib directory. Now I can
successfully JSP and corresponding beans through wizard but after deploying
it gives following error message:

-----------------------------------------------
javax.servlet.ServletException: Cannot find ActionMappings or
ActionFormBeans collection
	at
org.apache.jasper.runtime.PageContextImpl.handlePageException(PageContextImp
l.java:459)
	at
f_00025rm._0002fform_0002fregions_0002ejspregions_jsp_0._jspService(_0002ffo
rm_0002fregions_0002ejspregions_jsp_0.java:187)
	at
org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:119)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
	at
org.apache.jasper.servlet.JspServlet$JspCountedServlet.service(JspServlet.ja
va:130)
------------------------------------------------

Has anybody encountered the same problem? Or something Im forgetting to do?
Please guide me for the same.
Thanx in advance

Ketan Malekar

--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message