struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yibing Li" <...@gnxchange.com>
Subject RE: Multi-Lingual support
Date Thu, 18 Apr 2002 14:22:16 GMT
Could you tell me how to set up the locale in my browser? The only thing I
know
is that I have set the encoding under the view ( for IE ) to the appropriate
language I expect.

Thanks,

Yibing

-----Original Message-----
From: Tero P Paananen [mailto:tpp@viant.com]
Sent: Thursday, April 18, 2002 10:05 AM
To: Struts Users Mailing List
Subject: RE: Multi-Lingual support


>    1. have ApplicationResources.properties as English property file.
>    2. prepare a resource file for each language, in the case
> of Chinese, it
> is
>       ApplicationResources_zh_CN.properties in the same
> directory, with the
> content
>       translated to Chinese
>    3. Set init parameter of locale to true for ActionServlet
>    4. Start the server
>    5. Reset the locale of a computer
>    6. Browse the application
>
> However, what I see is still in English.
>
>
>    Do I miss anything? Please help.

Doublecheck that your browser is set up to send the correct
locale to the web server.

It's not the operating system that sends the locale to your
application, but the browser.

				-TPP

--
To unsubscribe, e-mail:
<mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:struts-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message