struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Barbara Post" <bab...@ifrance.com>
Subject Re: html: password and where has my password gone ?
Date Fri, 21 Jun 2002 13:43:37 GMT
You're very right Anand, my setter has a wrong name ! setPassword instead of
SetUserPassword :-/

Dumb mistake to avoid !

BP
----- Original Message -----
From: Anand Raman <araman@sapient.com>
To: 'Struts Users Mailing List' <struts-user@jakarta.apache.org>
Sent: Friday, June 21, 2002 3:39 PM
Subject: RE: html: password and where has my password gone ?


> make sure that the name for the password box has a appropriate getter in
the
> ActionForm. Struts will complain if you trying to display a form on a jsp
> but the ActionForm doesnt have a getter, but wont crib if a setter for the
> property is not present in the form.
>
> Hope this helps
> Anand
>
> -----Original Message-----
> From: Barbara Post [mailto:babs33@ifrance.com]
> Sent: Friday, June 21, 2002 7:07 PM
> To: struts-user@jakarta.apache.org
> Subject: html: password and where has my password gone ?
>
>
> I have :
>
> <html:password property="userPassword" size="10" tabindex="3"
> redisplay="false"/>
> in a simple <html:form... >
>
> When I press submit I always get the error message that means that my
> ActionForm got an empty String when getting the password !!
> getting userPassword variable.
>
> So where is my password ? In the reset() method I don't touch it, and in
the
> validate(...) method its value is lost. :-(
> So I even cannot login !
>
> Thx for any clue. Every other field works well.
>
> BP
>
>
> --
> To unsubscribe, e-mail:
> <mailto:struts-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
> <mailto:struts-user-help@jakarta.apache.org>
>


--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message