struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tadashi Ishikawa <ishik...@wink.tis.co.jp>
Subject Re: Newbie pls help: Anyone using JBoss 3 w/ Struts 1.1?
Date Fri, 21 Jun 2002 01:57:26 GMT
Hi Brian,

I've tried the URL http://localhost:8080/bad/saveRegistration.do
I saw input form normaly. Your ActionForm was created, wasn't it?
When I clicked 'Save', I saw blank-page, but no exception.

As I suggested at last post, JBoss already found *Your* ActionForm 
before WebClassLoader find it.
Remove Struts-related classes from your-ejb.jar file, then it will work.

Hope this helps.

Brian Topping wrote:

>Hi James & Ishikawa-san,
>
>Oh boy, my bad.  It was late when I posted, I should have stated that the
>problem URL is http://localhost:8080/bill2site-web/editRegistration.do.  Big
>difference there!!  Ack.
>
>Could I have you try again with that URL?
>
>Thanks so much!!
>
>Brian
>
>>-----Original Message-----
>>From: James Mitchell [mailto:jmitchtx@telocity.com]
>>Sent: Thursday, June 20, 2002 1:18 AM
>>To: Struts Users Mailing List
>>Subject: RE: Newbie pls help: Anyone using JBoss 3 w/ Struts 1.1?
>>
>>
>>Hi Brian,
>>
>>I posted on the jboss list about 20 minutes ago......just 
>>ignore that....
>>
>>I've got JBoss 3.0 Final w/ Tomcat 4.0.3 and I get this when 
>>submitting from
>>the first page.....
>>
>>
>>
>>Apache Tomcat/4.0.3 - HTTP Status 404 - /s/j_security_check
>>--------------------------------------------------------------
>>--------------
>>----
>>type Status report
>>message /s/j_security_check
>>description The requested resource (/s/j_security_check) is 
>>not available.
>>
>>your index.html is submitting the login to the above url.
>>I can't seem to find that anwhere in your config files.
>>
>>
>>James Mitchell
>>Software Engineer\Struts Evangelist
>>Struts-Atlanta, the "Open Minded Developer Network"
>>http://struts-atlanta.open-tools.org
>>
>>>-----Original Message-----
>>>From: Brian Topping [mailto:topping@digidemic.com]
>>>Sent: Thursday, June 20, 2002 12:47 AM
>>>To: struts-user@jakarta.apache.org
>>>Subject: Newbie pls help: Anyone using JBoss 3 w/ Struts 1.1?
>>>
>>>
>>>Hi All,
>>>
>>>I'm trying to get my first Struts app going.  I'm using 
>>>
>>JBoss3 with Tomcat
>>
>>>for the web container, and am having quite a bit of problems with
>>>getting my
>>>classes loaded.  It's what seems to be a common problem:
>>>"java.lang.NoClassDefFoundError:
>>>org/apache/struts/action/ActionForm".  There
>>>are a lot of solutions in the archives relating to moving 
>>>
>>jars underneath
>>
>>>WEB-INF, manifests, etc.  All I can say is that the struts.jar in
>>>this war is
>>>the only struts.jar on any classpath that I'm running under.  So
>>>if it's in
>>>the wrong location in this war (WEB-INF/lib), that may be 
>>>
>>my problem.
>>
>>>Anyone else using JBoss3+Tomcat4.0.3 release?
>>>
>>>I've got a war file at http://www.orb.org/bad.war that exhibits
>>>the problem.
>>>It works fine under Tomcat 4.0.4b3 standalone, it's simply a
>>>problem when the
>>>war is loaded under JBoss 3.  When it does the right thing, 
>>>
>>you'll get an
>>
>>>exception about not being able to locate an EJB in JNDI...
>>>
>>>I can post more information about the problem, but it seems the
>>>more I post,
>>>the harder the post is to read, so I'll start with this :)
>>>
>>>Any help appreciated, i'm sooooo close to getting all this running!!
>>>
>>>thanks a bunch,
>>>
>>>Brian
>>>
>>>--
>>>To unsubscribe, e-mail:
>>>
>><mailto:struts-user-unsubscribe@jakarta.apache.org>
>>For additional commands, e-mail:
>><mailto:struts-user-help@jakarta.apache.org>
>>
>>
>>
>>--
>>To unsubscribe, e-mail:   
>>
><mailto:struts-user-unsubscribe@jakarta.apache.org>
>For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>
>
>
>--
>To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
>For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>
>
>
>
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message