struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Morse" <rmo...@mdesignz.com>
Subject RE: Problem creating Validator Form in Action -- NEVERMIND
Date Sun, 02 Jun 2002 17:25:43 GMT
Nevermind.  Sorry for the noise.

-----Original Message-----
From: Robert Morse [mailto:rmorse@mdesignz.com]
Sent: Sunday, June 02, 2002 7:27 AM
To: Struts Users Mailing List
Subject: Problem creating Validator Form in Action


This is a very strange problem for me, and I'm guessing that the solution is
simple, but I'm just not making the connection.

My environment is Struts 1.1 beta, using Tiles and Validator for the same
distribution.

I have a series of forms that get populated as a user navigates through the
application.  Data entered on one form, may appear on others.  This causes
me to instantiate and pre-populate the form beans during a preceding action.
So, the first form displays and the user enters some information and submits
the form.  The data is validated by the validation package, and the Action
for that form is finally called.  During that action, I create a new form
bean for the next form, and save it by request.setAttribute("formname",
form).  Note:  I've also tried session.setAttribute with the same results.
At the end of this action, I then return (mapping.findForward("success")).

Tiles, inserts the appropriate jsp files, but the next form complains that
the getter methods for the form bean that I created in the prior action are
null.

I've looked through examples, and archives, but can't seem to find something
similar to this.  Any ideas?


--
To unsubscribe, e-mail:
<mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:struts-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message