struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Gréhalle <ngreha...@rennes.jouve.fr>
Subject Re: Jetty 4.0 and Struts 1.1b1
Date Thu, 25 Jul 2002 14:59:07 GMT
My web.xml contains :

<servlet>
    <servlet-name>action</servlet-name>
    <servlet-class>org.apache.struts.action.ActionServlet</servlet-class>
    <init-param>
      <param-name>application</param-name>

<param-value>com.elscdweb.controller.ApplicationResources</param-value>
    </init-param>
    <init-param>
      <param-name>config</param-name>
      <param-value>/WEB-INF/struts-config.xml</param-value>
    </init-param>
    <init-param>
      <param-name>detail</param-name>
      <param-value>2</param-value>
    </init-param>
    <init-param>
      <param-name>debug</param-name>
      <param-value>2</param-value>
    </init-param>
    <init-param>
      <param-name>validate</param-name>
      <param-value>true</param-value>
    </init-param>
    <init-param>
       <param-name>config</param-name>
       <param-value>/WEB-INF/struts-config.xml</param-value>
    </init-param>
    <load-on-startup>1</load-on-startup>
  </servlet>

and my file ApplicationResources.properties is in com/elscdweb/controller

I've not the normal message :
action : init
action : Loading application ressources ....
action : Initializing .....


The project works under Tomcat. That's really strange





----- Original Message -----
From: Jon.Ridgway <Jon.Ridgway@upco.co.uk>
To: 'Struts Users Mailing List' <struts-user@jakarta.apache.org>
Sent: Thursday, July 25, 2002 4:44 PM
Subject: RE: Jetty 4.0 and Struts 1.1b1


> Hi Nicolas,
>
> Have you double checked your web.xml, does it contain an application init
> param for the action servlet. If it does, do you have the specified
> properties file in the location indicated by the param value?
>
> Jon Ridgway
>
>
> -----Original Message-----
> From: Nicolas Gréhalle [mailto:ngrehalle@rennes.jouve.fr]
> Sent: 25 July 2002 15:38
> To: Struts Users Mailing List
> Subject: Jetty 4.0 and Struts 1.1b1
>
> Hi,
>
> I'm developping a Struts project with Tomcat 4 and all works.
> But I've tried to put my project under Jetty 4.0 and i've the following
> error message :
>
> HTTP ERROR: 500 Cannot find message resources under key
> org.apache.struts.action.MESSAGE
>
> It seems to me that no resources have been loaded.
>
> Any idea ?
>
> Thanks
>
> N.G.
>
>
>
>
> --
> To unsubscribe, e-mail:
> <mailto:struts-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
> <mailto:struts-user-help@jakarta.apache.org>
>
>
> The contents of this email are intended only for the named addressees and
> may contain confidential and/or privileged material. If received in error
> please contact UPCO on +44 (0) 113 201 0600 and then delete the entire
> e-mail from your system. Unauthorised review, distribution, disclosure or
> other use of this information could constitute a breach of confidence.
Your
> co-operation in this matter is greatly appreciated.
>
> --
> To unsubscribe, e-mail:
<mailto:struts-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
<mailto:struts-user-help@jakarta.apache.org>
>
>


--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message