struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eddie Bush <ekb...@swbell.net>
Subject Re: Problem validating dynamic Form with Validator-Framework
Date Wed, 31 Jul 2002 18:18:26 GMT
That's it!  It's got to be!  Yes - you must always specify 
dynamic="true" for these dynamic forms! :-)  Bleh - please post things 
in a "nicer" format next time you have to post things.  Some of us are 
spoiled to well-formatted configs and just can't read jumbled up messes 
very well.

struts-user@japache.org wrote:

>Depending on which version of Struts you are using, you might need to set the dynamic
attribute to true like this:
>
><form-bean 
>  dynamic="true"
>  name="createStandortForm"
>  type="org.apache.struts.validator.DynaValidatorActionForm">
><!-- Form Property stuff here -->
></form-bean>
>
>I can't remember off the top of my head whether you needed to do this for the DynaValidatorActionForm.
I know that this has been changed so the framework can now induce whether the class in the
type attribute is a subclass of DynaActionForm, but it hasn't always been that way.
>
>If you using the latest nightly and this problem still happens, then this is probably
not it. If you are using an older version of 1.1b (maybe a couple of weeks old), then try
adding this attribute or getting the latest version.
>
>HTH,
>Chuck
>



--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message