struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Mulligan <david.mulli...@LECAN.ie>
Subject RE: problem with HttpSession in Resin-2.1.2
Date Wed, 24 Jul 2002 15:08:33 GMT
Now I'm really confused!!!

I'm using Velocity for the presentation, so no JSPs or tags. 
I'm guessing the LOCALE attribute is coming from the web 
browser! I also tried setting the session-timeout to 30 
minutes in web.xml and that didn't work either.

But this is where things get really strange! 

I started up K-Meleon (Mozilla browser) to check and see if 
MS-IE was sending my location in the request (Hence the 
LOCALE attribute) and everything worked just fine! 

Not one problem! I can login/logout etc. UserBean is getting 
saved in the Session. Everything works as expected!

Back to IE and it still doesn't work. IE is setup to check 
for newer page version with each request. So it's not a 
problem with the cache. 

Anyone else ever see something like this before?


-----Original Message-----
From: Jonathan Fuerth [mailto:fuerth@sqlpower.ca]
Sent: Wednesday, July 24, 2002 3:31 PM
To: Struts Users Mailing List
Subject: Re: problem with HttpSession in Resin-2.1.2


On Tue, Jul 23, 2002 at 06:06:08PM +0100, David Mulligan wrote:
> Everthing works just fine on Tomcat 4.0.3 and Websphere. 
> But for some strange reason the HttpSession I create in my LogonAction
loses
> an attribute (The UserBean) in the next request (only with Resin)!

Are there any JSPs involved in your testing?  They always seem to
create a session when they start up.  If for some reason (short
timeout or otherwise) the initial session you created and put the user
bean into was invalid when a JSP started, it would create a new
(empty) session, which could be what you're seeing in that second
servlet.  The locale attribute probably comes from a <html:html
locale="true"> tag in your JSP (assuming you are using a JSP).

Do try and set the session timeout in web.xml (as you mentioned).. a
very short session timeout is one possible explanation for what's
going on.

I don't know if this will help you solve the problem, but that's my
best guess at what's happening to your session.  Good luck with it!

-- 
Jonathan Fuerth - SQL Power Group Inc.
(416)218-5551 (Toronto); 1-866-SQL-POWR (Toll-Free)
Unleash the Power of your Corporate Data - http://www.sqlpower.ca/

--
To unsubscribe, e-mail:
<mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:struts-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message