struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dmk...@earthlink.net (David M. Karr)
Subject ActionServlet.init() not called for identical application
Date Thu, 29 Aug 2002 06:03:21 GMT
I have the "struts-exercise-taglib" application, using Struts.  When I execute
the "html:link" test, it works fine.

I also have an application called "strutsel-exercise-taglib", built using my
derived Struts-EL library, and Struts.  Presently, the application is almost
identical, except for some references to "-el" tags instead of non-el tags.  In
the case of the "html:link" test, it is still using the normal Struts tags
(although I'm also importing the "-el" tag libraries).

I'm using Struts-1.1-b2, built from source.

When I start up Tomcat (4.0.4) in netbeans, it hits a breakpoint at
ActionServlet.init() and loads the configuration.

Note that I have both applications in the "webapps" directory (unpacked).

I would have thought I would hit the ActionServlet.init() breakpoint twice,
once for each application.

When I run the normal Struts test, the "html:link" test works fine.  When I run
my derived test, the "html:link" fails, saying that it couldn't find any action
mappings.  In the debugger, I see that the "ApplicationConfig" is null.  I
would guess this is the case because it didn't execute ActionServlet.init() for
this application.

I'm awfully confused.  Am I just doing something very silly that is causing
this, or is there something subtle I need to deal with?

-- 
===================================================================
David M. Karr          ; Java/J2EE/XML/Unix/C++
dmkarr@earthlink.net


--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message