struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Taylor, Jason" <jtay...@cobaltgroup.com>
Subject RE: Startup Problem
Date Thu, 26 Sep 2002 17:21:12 GMT
LOOK AT YOUR CONSOLE!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

-----Original Message-----
From: Kalaiselvan [mailto:kalaiselvan@HotPOP.com]
Sent: Thursday, September 26, 2002 6:32 AM
To: Struts Users Mailing List
Subject: Startup Problem


Hi All,

Here i'm facing serious problem..
I already configured test application in Struts.

But when I configure my original Application i face serious problem..

I got an error like

"No action instance for path /login could be created"
"The server encountered an internal error (No action instance for path
/login could be created) that prevented it from fulfilling this request."

I gave my code here

struts-config.xml
--------------------

<?xml version="1.0" encoding="ISO-8859-1"?>

<!DOCTYPE struts-config PUBLIC
          "-//Apache Software Foundation//DTD Struts Configuration 1.0//EN"
          "http://jakarta.apache.org/struts/dtds/struts-config_1_0.dtd">

<struts-config>
    <form-beans>
        <form-bean name="loginForm" type="com..login.LoginForm"/>
    </form-beans>
    <global-forwards>
        <forward   name="error"  path="/login.jsp"/>
    </global-forwards>
    <action-mappings>
        <action    path="/login"
                   type="com.login.LoginAction"
                   name="loginForm"
                   scope="request"
                   input="/login.jsp">
         <forward name="success" path="/home.jsp"/>          
        </action>
    </action-mappings>
</struts-config>

web.xml
---------

<?xml version="1.0" encoding="ISO-8859-1"?>

<!DOCTYPE web-app
  PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.2//EN"
  "http://java.sun.com/j2ee/dtds/web-app_2_2.dtd">

<web-app>

  <!-- Action Servlet Configuration -->
  <servlet>
    <servlet-name>action</servlet-name>
    <servlet-class>org.apache.struts.action.ActionServlet</servlet-class>
    <init-param>
      <param-name>application</param-name>
 
<param-value>com.openwave.careertracks.ApplicationResources</param-value>
    </init-param>
    <init-param>
      <param-name>config</param-name>
      <param-value>/WEB-INF/struts-config.xml</param-value>
    </init-param>
    <init-param>
      <param-name>debug</param-name>
      <param-value>2</param-value>
    </init-param>
    <init-param>
      <param-name>detail</param-name>
      <param-value>2</param-value>
    </init-param>
    <init-param>
      <param-name>validate</param-name>
      <param-value>true</param-value>
    </init-param>
    <load-on-startup>1</load-on-startup>
  </servlet>


  <!-- Action Servlet Mapping -->
  <servlet-mapping>
    <servlet-name>action</servlet-name>
    <url-pattern>*.do</url-pattern>
  </servlet-mapping>


  <!-- The Welcome File List -->
  <welcome-file-list>
    <welcome-file>login.jsp</welcome-file>
  </welcome-file-list>

  <!-- Application Tag Library Descriptor -->
  <taglib>
    <taglib-uri>/WEB-INF/app.tld</taglib-uri>
    <taglib-location>/WEB-INF/app.tld</taglib-location>
  </taglib>

  <!-- Struts Tag Library Descriptors -->
  <taglib>
    <taglib-uri>/WEB-INF/struts-bean.tld</taglib-uri>
    <taglib-location>/WEB-INF/struts-bean.tld</taglib-location>
  </taglib>

  <taglib>
    <taglib-uri>/WEB-INF/struts-html.tld</taglib-uri>
    <taglib-location>/WEB-INF/struts-html.tld</taglib-location>
  </taglib>

  <taglib>
    <taglib-uri>/WEB-INF/struts-logic.tld</taglib-uri>
    <taglib-location>/WEB-INF/struts-logic.tld</taglib-location>
  </taglib>
</web-app>

login.jsp
-----------
<%@ taglib uri='/WEB-INF/struts-template.tld' prefix='template' %>

<template:insert template='/logintemplate.jsp'>
  <template:put name='title' content='Strus' direct='true'/>
  <template:put name='header' content='/header.htm' />
  <template:put name='content' content='/login.htm'/>
  <template:put name='footer' content='/footer.htm' />
</template:insert>

login.html
------------
<form>
<table align="center" cellpadding="0" cellspacing="0">
        <td class="text11bold">&nbsp;&nbsp;&nbsp;Username:&nbsp;&nbsp;<input
class="inbox" type="text" name="userName" value="" size="15"></td>
    </tr>
    <tr></tr>
    <tr>
        <td class="text11bold">&nbsp;&nbsp;&nbsp;Password:&nbsp;&nbsp;<input
class="inbox" type="password" name="password" size="15"> 
<a href="login.do"><img src="images/login_button.gif"
border="0"></a></td></table>
</form>


Please help
where i made a mistake..

Thanx in Advance

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message