struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian Lee" <brian_a_...@hotmail.com>
Subject "Multipart data doesn't start with boundary" error when forwarding
Date Wed, 04 Sep 2002 22:25:24 GMT
I'm getting the following error: "Multipart data doesn't start with 
boundary" when I attempt to forward a request on to another action.

Here's my config:
<action path="/createPub"
    		type="com.nciinc.sde.console.publish.CreatePublishingAction"
    		name="createPubForm"
    		scope="request"
    		input="/createPubView.do"
    		validate="true">
    	<forward name="success" path="/createPubView.do"/>
    </action>

The action class executes and then I get the above error when trying to 
forward on to the success action. I also get the error if validation fails 
and I try to forward on the input action.

The createPubView action calls a very simple Action class that just clears a 
VO out of the session and forwards to a JSP.

The createPubView action class is never invoked as struts errors out prior 
to calling the action. It looks like it errors when trying to populate my 
form (from the looks of the stack trace).

I do not get the error if I replace the input or forward with an input or 
forward directly to the JSP and not to an action.

I have read about this error on the mailing list archive but cannot resolve 
the problem successfully. I have the latest build that has the 
RequestProcessor patch.

Any help is appreciated.

Thanks,
BAL

_________________________________________________________________
Send and receive Hotmail on your mobile device: http://mobile.msn.com


--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message