struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sutiwan Kariya" <Suti...@tisco.co.th>
Subject Relative Path Error-- Pls help!
Date Mon, 09 Sep 2002 09:55:42 GMT
I am using struts runs on IBM WebSphere 4.0
my web site 's name (context root) is  'td'
I got an image location error when use
<img src = "/images/general_active_tab.gif" >
or
<html:image src = "/images/address_passive_tab.gif"   border= "0"/>

But, if I tried
<img src = "/td/images/general_active_tab.gif" >
or
<html:image src = "/td/images/address_passive_tab.gif"   border= "0"/>

The image was displayed correctly
Why??????
I feel like the "/" doesn't relate to the context root. but it relate to
the root of context root.

This symptom didn't occur with the image tag only BUT It occur when I tried
to use
 <html:button property="add" onclick="window.location
= '/institutionGeneralInfo.do?action=create'"

It got an error also.
but, If I tried
 <html:button property="add" onclick="window.location
= '/td/institutionGeneralInfo.do?action=create'"
It's OK!


Please help me...
Sutiwan W.





********************************************************************
This E-mail and any files transmitted with it are confidential
and intended for the sole use of the individual or entity
to whom they are addressed. If you have received this 
E-mail in error please notify the system manager.  This E-mail
message has been swept for the presence of computer
viruses.
********************************************************************


--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message