struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From DjTweed <djtw...@yahoo.com>
Subject Problem with Jrun
Date Thu, 03 Oct 2002 16:49:00 GMT
Hello,
I'm running Jrun 3.1 (latest patch) on WinXP Pro with IIS.  I have had
this config for 2+ years and it works great. Lately I have been playing
with Struts 1.1 beta.   After intalling the struts example app, I get the
following error when loading the index.jsp page.

500 Internal Server Error
	<PRE> <B>/strutsexample/:</B> Exception thrown processing JSP page.
java.lang.NoClassDefFoundError at
org.apache.struts.taglib.bean.MessageTag.doStartTag(MessageTag.java:295)
at jrun__index2ejspa._jspService(jrun__index2ejspa.java:58) at
allaire.jrun.jsp.HttpJSPServlet.service(HttpJSPServlet.java:39) at
allaire.jrun.jsp.JSPServlet.service(JSPServlet.java:228) at
allaire.jrun.jsp.JSPServlet.service(JSPServlet.java:196) at
allaire.jrun.servlet.JRunSE.service(JRunSE.java:1417) at
allaire.jrun.session.JRunSessionService.service(JRunSessionService.java:1106)
at allaire.jrun.servlet.JRunSE.runServlet(JRunSE.java:1271) at
allaire.jrun.servlet.JRunRequestDispatcher.forward(JRunRequestDispatcher.java:89)
at allaire.jrun.file.FileServlet.service(FileServlet.java:178) at
allaire.jrun.servlet.JRunServletPool.service(JRunServletPool.java:90) at
allaire.jrun.servlet.JRunSE.service(JRunSE.java:1417) at
allaire.jrun.session.JRunSessionService.service(JRunSessionService.java:1106)
at allaire.jrun.servlet.JRunSE.runServlet(JRunSE.java:1271) at
allaire.jrun.servlet.JRunRequestDispatcher.forward(JRunRequestDispatcher.java:89)
at allaire.jrun.servlet.JRunSE.service(JRunSE.java:1557) at
allaire.jrun.servlet.JRunSE.service(JRunSE.java:1547) at
allaire.jrun.servlet.JvmContext.dispatch(JvmContext.java:364) at
allaire.jrun.jrpp.ProxyEndpoint.run(ProxyEndpoint.java:388) at
allaire.jrun.ThreadPool.run(ThreadPool.java:272) at
allaire.jrun.WorkerThread.run(WorkerThread.java:75) </PRE> 

I do NOT have any struts.jar files in any location other then the
WEB-INF/lib for the application.  (along with all the COMMONS*.jars)

I've read and search all over to no avail.  I installed Struts .9 while
back, and i remember it worked fine.

Thanks in advance for any ideas,
George
djtweed@yahoo.com

__________________________________________________
Do you Yahoo!?
New DSL Internet Access from SBC & Yahoo!
http://sbc.yahoo.com

--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message