struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig R. McClanahan" <craig...@apache.org>
Subject RE: Does Anyone Know What This Error Message Means?
Date Thu, 17 Oct 2002 22:12:59 GMT
The struts-example and struts-blank webapps work out of the box on
virtually every other server -- and I do know for a fact that they don't
rely on any "magic" specific to any one server.

The exception you are getting implies that they don't have their class
loading environment set up correctly when the init() method of a
load-on-startup servlet is invoked.  If that's really the cause, then it
is absolutely a bug in the container.

Craig

On Thu, 17 Oct 2002, Haseltine, Celeste wrote:

> Date: Thu, 17 Oct 2002 16:15:08 -0500
> From: "Haseltine, Celeste" <CHaseltine@magticket.com>
> Reply-To: Struts Users Mailing List <struts-user@jakarta.apache.org>
> To: 'Struts Users Mailing List' <struts-user@jakarta.apache.org>
> Subject: RE: Does Anyone Know What This Error Message Means?
>
> Craig,
>
> Do you know this for a fact?  I've looked through the Bugzilla for Struts,
> and noted that the pre-loading issue for the ActionServlet in JRUN 3.1 was
> reported, and I thought fixed, in Struts 1.1b2. A message on the JRUN
> listserver states that the preloading of the action servlet has to be
> removed from the JRUN management console in order to get Struts 1.1b2
> example and blank apps to work.  Or at least that was my understanding.  As
> is usual, I am unable to get any acknowledgement from the JRUN support group
> one way or the other, so I am hoping that someone on this listserver has
> either actually gotten Struts 1.1b2 working in JRUN 3.1, or knows for a fact
> that it will NOT work in JRUN 3.1.
>
> Celeste
> -----Original Message-----
> From: Craig R. McClanahan [mailto:craigmcc@apache.org]
> Sent: Thursday, October 17, 2002 2:40 PM
> To: Struts Users Mailing List
> Subject: RE: Does Anyone Know What This Error Message Means?
>
>
>
>
> On Thu, 17 Oct 2002, Haseltine, Celeste wrote:
>
> >
> > To my knowledge, no one on the JRUN message board has been able to get
> > Struts 1.1b2 working in JRUN 3.1.
>
> It is not a Struts bug.
>
>   Although I don't really know Struts, I
> > would like to use it on our next project, and we are unable to upgrade to
> > JRUN 4.0 because of budget constraints.  Can you think of anything else
> for
> > me to try and get the 1.1b2 versions of the struts-example or the
> > struts-blank apps working?
> >
>
> Convince the JRun folks to fix their load-on-startup processing code.
>
> > Thanks in advance for all your assistance!!!
> >
> > Celeste Haseltine, PE
> > MTL, Inc.
> >
>
> Craig
>
>
> --
> To unsubscribe, e-mail:
> <mailto:struts-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
> <mailto:struts-user-help@jakarta.apache.org>
>
> --
> To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>
>
>


--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message