struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jerry Jalenak" <Jerry.Jale...@LABONE.com>
Subject RE: JDK 1.4 and struts
Date Mon, 21 Oct 2002 16:20:09 GMT
+1

I've been running Struts 1.1b2 on Win-NT (service pack 6), RedHat 7.2, and
RedHat 7.3 - all with J2SDK 1.4.0_01 - and have had no classpath issues. I
often complete a module on my Win-NT system, drag it to my Linux test box,
drop it in the web app and test without making any changes....

Jerry

> -----Original Message-----
> From: Craig R. McClanahan [mailto:craigmcc@apache.org]
> Sent: Monday, October 21, 2002 11:15 AM
> To: Struts Users Mailing List
> Subject: Re: JDK 1.4 and struts
> 
> 
> 
> 
> On 21 Oct 2002, Umberto Nicoletti wrote:
> 
> > Date: 21 Oct 2002 17:24:15 +0500
> > From: Umberto Nicoletti <unicoletti@prometeo.it>
> > Reply-To: Struts Users Mailing List <struts-user@jakarta.apache.org>
> > To: Struts Users Mailing List <struts-user@jakarta.apache.org>
> > Subject: Re: JDK 1.4 and struts
> >
> > On Sun, 2002-10-20 at 05:21, email wrote:
> > >
> > > There were a couple of messages the other day concerning 
> Struts failing
> > > to work correctly under the 1.4 JDK. I'd like to add some 
> evidence to that.
> > >
> > > Sun's 1.4 JDK (at least the Linux version) seems to have serious
> > > problems w/ the classpath. After upgrading to 1.4.0_01, and then
> > > 1.4.1_01, Struts no longer works on my machine. Specifically, when
> > > dispatching to an Action subclass, the JVM cannot seem to find
> > > org.apache.struts.action.Action -- despite knowing all about
> > > ActionServlet and a bunch of other classes in the struts.jar file.
> > >
> > > Someone stated recently that Struts DOES WORK w/ JDK1.4. 
> Which OS is
> > > that? And does anyone have positive experience using 
> Struts w/ JDK1.4 on
> > > Linux?
> > >
> > I have RedHat linux 7.2 (with the latest patches), latest 
> SUN JDK and
> > latest Tomcat.
> > I'm using Struts 1.1b2 and it works.
> >
> 
> This pretty much corresponds to the environment in which I 
> develop Struts.
> It works fine with JDK 1.4.1 on Linux.
> 
> > umberto
> 
> Craig
> 
> 
> --
> To unsubscribe, e-mail:   
> <mailto:struts-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: 
> <mailto:struts-user-help@jakarta.apache.org>
> 
> 

This transmission (and any information attached to it) may be confidential and is intended
solely for the use of the individual or entity to which it is addressed. If you are not the
intended recipient or the person responsible for delivering the transmission to the intended
recipient, be advised that you have received this transmission in error and that any use,
dissemination, forwarding, printing, or copying of this information is strictly prohibited.
If you have received this transmission in error, please immediately notify LabOne at (800)388-4675.



--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message