struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Haseltine, Celeste" <CHaselt...@magticket.com>
Subject Struts 1.1b2 Example Application
Date Wed, 30 Oct 2002 21:32:57 GMT
I am trying to get Struts 1.1b2 working in JRUN 3.1, and I think I am
getting closer.  I have added the <load-on-startup>1</load-on-startup>
parameter to my web.xml file for the action servlet, which eliminated one
error I was getting.  I am now getting the following in my web applications
err.log file:

 
java.lang.ClassNotFoundException:org.apache.struts.util.PropertyMessageResou
rcesFactory

which in turn means that I am unable to pre-load the action servlet.  I get
the following error message in my web applications event.log file:

10/30 15:12:42 error (JRun) Could not pre-load servlet: action
[javax.servlet.ServletException: Could not instantiate
org.apache.struts.action.ActionServlet]
[1]java.lang.NullPointerException
	at
org.apache.struts.util.MessageResources.getMessageResources(MessageResources
.java:558)
	at
org.apache.struts.action.ActionServlet.initInternal(ActionServlet.java:1153)
	at ..............

I have gone through the archives, and I found two suggestions, both of which
I have tried.  Neither seems to have had any effect, but I have added an
init parameter to my action servlet class for the
ApplicationResources.property file, and a KEY value to message resources tag
in the Struts-config.xml file as follows:

web.xml added this to action servlet:

	<init-param>
	  <param-name>application</param-name>
	
<param-value>org.apache.struts.webapp.example.ApplicationResources</param-va
lue>
	</init-param>

struts-config.xml added KEY parameter to message resource tag:
	<message-resources
 
parameter="org.apache.struts.webapp.example.ApplicationResources"
    		key="org.apache.struts.action.MESSAGE"/>

Does any have any other suggestions as to what I should try, or an
understanding as to what is happening?????

By the way, the error message I am getting on my browser is as follows:

	500 Internal Server Error
<PRE> <B>/struts-example/:</B> Exception thrown processing JSP page.
java.lang.NoClassDefFoundError at
org.apache.struts.taglib.bean.MessageTag.doStartTag(MessageTag.java:295) at
jrun__index2ejspa._jspService(jrun__index2ejspa.java:58) at
allaire.jrun.jsp.HttpJSPServlet.service(HttpJSPServlet.java:39) at
allaire...................................

Any assistance would be appreciated!!!!!

Celeste Haseltine, PE
MTL, Inc
Dallas, TX




--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message