struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karr, David" <david.k...@attws.com>
Subject RE: Struts-Tiles
Date Fri, 18 Oct 2002 20:28:29 GMT
Perhaps it isn't clear, but you need to deploy "struts.jar" along with
"strutsel.jar", not to mention "jstl.jar" and "standard.jar".

> -----Original Message-----
> From: Chen, Gin [mailto:Gin_Chen@tvratings.com]
> Sent: Friday, October 18, 2002 1:15 PM
> To: 'Struts Users Mailing List'
> Subject: Struts-Tiles
> 
> 
> Hi all,
> 	I'm using the Struts-El library and tiles.
> 	I downloaded the latest nightly build. But when I try 
> to deploy, I
> get the following:
> 
> java.lang.ClassNotFoundException:
> org.apache.struts.tiles.xmlDefinition.XmlDefinition
>         at
> org.jboss.mx.loading.UnifiedLoaderRepository2.loadClass(Unifie
> dLoaderReposit
> ory2.java:166)
>         at
> org.jboss.mx.loading.UnifiedClassLoader.loadClass(UnifiedClass
> Loader.java:28
> 3)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:255)
>         at
> org.apache.commons.digester.ObjectCreateRule.begin(ObjectCreat
> eRule.java:252
> )
>         at
> org.apache.commons.digester.Digester.startElement(Digester.java:1237)
>         at 
> org.apache.crimson.parser.Parser2.maybeElement(Parser2.java:1488)
>         at 
> org.apache.crimson.parser.Parser2.content(Parser2.java:1779)
>         at 
> org.apache.crimson.parser.Parser2.maybeElement(Parser2.java:1507)
>         at 
> org.apache.crimson.parser.Parser2.parseInternal(Parser2.java:500)
>         at org.apache.crimson.parser.Parser2.parse(Parser2.java:305)
>         at
> org.apache.crimson.parser.XMLReaderImpl.parse(XMLReaderImpl.java:442)
> .. alot more ...
> 
> Anyone know what might be causing this?
> I opened up struts.jar and I can see that the class is there.
> And the log (using jboss-3.0.3_tomcat-4.1.12) seems to show 
> that it got
> deployed just fine.
> 
> 16:00:58,913 INFO  [Engine] WebappLoader[/NAM]: Deploy JAR
> /WEB-INF/lib/struts.jar to
> C:\jboss-3.0.3_tomcat-4.1.12\tomcat-4.1.x\work\MainEngine\loca
> lhost\NAM\WEB-
> INF\lib\struts.jar
> 
> So why isnt it picking it up?
> 
> Thanks,
> -Tim
> 
> --
> To unsubscribe, e-mail:   
<mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:struts-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message