struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Tse" <eric...@netvigator.com>
Subject ApplicationResources in UTF-8
Date Fri, 27 Dec 2002 19:57:33 GMT
Hi Vipul,

Thanks for your mail. I know what you mean. But even I tried to set the
locale to hk, it works neither :)

I know the root cause to my problem. The filename of application resource
should be "ApplicationResources_zh-HK.properties" instead of
"ApplicationResources_zh_hk.properties".

rana >> thanks!

BTW, when i load the message resource file in UTF-8 formats, the browser
windows does not change the default encoding to UTF-8. I can see the
characters correctly if i manually switch the browser codeset.

But when I added page contentType="text/html;charset=utf-8" or
"pageEncoding=utf-8" at JSP page directive, the characters become
unrecognized symbols. I also tried to include
contentType="text/html;charset=UTF-8" in controller element of
struts-config.xml. Not work neither.

Any idea?

Regards,
Eric

----- Original Message -----
From: "Vipul Sanghi" <vipul@zimono.com>
To: "Struts Users Mailing List" <struts-user@jakarta.apache.org>
Sent: Thursday, December 26, 2002 1:39 PM
Subject: RE: ApplicationResources


> The locale that you are specifying does not include the country extention.
> It only knows of zh because you are probably doing new Locale("zh").  You
> have to use the country variant when you instantiate and set the locale  i
> think it is you have to do new Locale("zh", "hk") to pick traditional
> chinese etc.
>
> Vipul
>
> -----Original Message-----
> From: Eric Tse [mailto:erictks@netvigator.com]
> Sent: Thursday, December 26, 2002 11:27 AM
> To: Struts Users Mailing List
> Subject: ApplicationResources
>
>
> Dear all,
>
> I am trying to feed in 3 languages on my web, i.e. English (en-us),
> Traditional Chinese (zh-hk), and Simplified Chinese (zh-cn).
>
> I named the application resources as follows:
>
> ApplicationResources.properties           (for en-us)
> ApplicationResources_zh.properties          (for zh-hk)
>
> they work!! But when the following settings apply....
>
> ApplicationResources.properties           (for en-us)
> ApplicationResources_zh_hk.properties          (for zh-hk)
> ApplicationResources_zh_cn.properties          (for zh-cn)
>
> only en-us works! :~(
>
> any hint?
>
> Regards,
> eric
>
>
>
>
>
> --
> To unsubscribe, e-mail:
<mailto:struts-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
<mailto:struts-user-help@jakarta.apache.org>
>


--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message