struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cedric Dumoulin <ced...@apache.org>
Subject Re: org.apache.struts.tiles.actions.NoOpAction
Date Wed, 18 Dec 2002 13:13:10 GMT

  Hi,

  The parameter attribute should be the name of the tile, as it appears 
in your tile definitions file. Check that the definition exist, and that 
the Tiles factory is successfully loaded.

   Hope this help,

        Cedric

Björn Pewe wrote:

>Hi, I saw that org.apache.struts.tiles.actions.NoOpAction is deprecated and
>that o.a.s.a.ForwardAction should be used instead. But when I use
>ForwardAction to forward to a tiles def I get a mapping error. I'm using
>modules and it doesn't matter if I append the module name before the tile
>def. It seems to me that the TilesRequestProcessor either isn't called or
>don't trigger on the tiles-def name. What am I missing here?
>Example of my action mapping:
><action path="/test" type="org.apache.struts.actions.ForwardAction"
>parameter=".test.def" /> 
>or
><action path="/test" type="org.apache.struts.actions.ForwardAction"
>parameter="module/.test.def" /> 
>/Björn
>
>--
>To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
>For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>
>
>
>  
>


--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message