struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sterin, Ilya" <Iste...@ciber.com>
Subject RE: Problem with simple welcome.jsp page
Date Mon, 23 Dec 2002 19:50:20 GMT
Thanks to all that responded, clearing the tomcat cache did the job:-)
Thanks a bunch.  My tomcat was set to reload on each request, but not sure
why it didn't:-)

Appreciate everyone's help.

Ilya

-----Original Message-----
From: James Mitchell [mailto:jmitchell@apache.org]
Sent: Monday, December 23, 2002 1:15 PM
To: 'Struts Users Mailing List'
Subject: RE: Problem with simple welcome.jsp page


I've had those same problems in the past.

Here's how I troubleshoot it.

1. Browser
 Make sure that the browser isn't caching the page.
 Verify your settings, and if still in doubt, close the browser and open
a new one.

2. Container
 Is the container re-compiling the jsp?
 Check the settings in the config files.
 In Tomcat, you can also just delete the directories where they are
compiled.

For me:

 $TOMCAT_HOME/work/Standalone/localhost/whatever-app


That might not be the official way of doing it, but it works for me.

--
James Mitchell
Software Engineer/Open Source Evangelist
http://www.open-tools.org

"C makes it easy to shoot yourself in the foot; C++ makes it harder, but
when you do, it blows away your whole leg."
- Bjarne Stroustrup


> -----Original Message-----
> From: Sterin, Ilya [mailto:Isterin@ciber.com]
> Sent: Monday, December 23, 2002 12:21 PM
> To: struts-user@jakarta.apache.org
> Subject: Problem with simple welcome.jsp page
>
>
> I'm having a problem displaying the page.  I'm using the
> logon example from the "Struts in Action" book, but
> substituted the .jsp pages with my own versions.  Now, before
> I did the substitutions, it displayed the default welcome
> page, provided with example, when I substituted with my own and
> **even** restarted the server, which is not needed of course,
> I continue getting the old version of the page, instead of
> the new one?
>
> Does anyone know why this is happening?  I know I'm working
> with the right file, because if I delete Wecome.jsp, I get an
> error that the page is not found.
>
> Please, please help:-)
>
> Thanks.
>
> Ilya
>
> --
> To unsubscribe, e-mail:
> <mailto:struts-user-> unsubscribe@jakarta.apache.org>
> For
> additional commands,
> e-mail: <mailto:struts-user-help@jakarta.apache.org>
>
>


--
To unsubscribe, e-mail:
<mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:struts-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message