struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen.Chamb...@transplace.com
Subject RE: Error loading struts-config
Date Mon, 23 Dec 2002 14:28:39 GMT

I'm not certain, but are you sure that your DTD's are being found? We once
had a similar problem due to firewall issues.

Steve



                                                                                         
                                       
                    "Robert                                                              
                                       
                    Taylor"              To:     "Struts Users Mailing List" <struts-user@jakarta.apache.org>,
                  
                    <rtaylor@mulew        <me@howardmiller.co.uk>               
                                                
                    ork.com>             cc:                                          
                                          
                                         Subject:     RE: Error loading struts-config    
                                       
                    12/23/2002                                                           
                                       
                    08:21 AM                                                             
                                       
                    Please respond                                                       
                                       
                    to "Struts                                                           
                                       
                    Users Mailing                                                        
                                       
                    List"                                                                
                                       
                                                                                         
                                       
                                                                                         
                                       




Looks like the ActionServlet cannot find the config file at all. Make sure
the config parameter of the ActionServlet entry in web.xml is pointing to
the struts-config.xml file.

robert

> -----Original Message-----
> From: Howard Miller [mailto:me@howardmiller.co.uk]
> Sent: Monday, December 23, 2002 8:59 AM
> To: struts-user@jakarta.apache.org
> Subject: Error loading struts-config
>
>
> Hi,
>
> I am just setting up a new Struts project. I have the Action servlet set
> up and a struts-config.xml with almost nothing in it. When the war is
> installed the servlet starts and then throws this error...
>
> 2002-12-23 13:47:11 StandardContext[/quest]: Servlet /quest threw
> load() exception
> javax.servlet.UnavailableException: Parsing error processing
> resource path /WEB-INF/struts-config.xml
>          at
> org.apache.struts.action.ActionServlet.initApplicationConfig(ActionS
> ervlet.java:866)
>          at
> org.apache.struts.action.ActionServlet.init(ActionServlet.java:455)
> ...lots more....
>
> I have no idea what's gone wrong. I seem to get the error regardless
> of what's in the struts-config file or even if I remove it alltogether.
>
> As the error message appears to be no help... has anybody got any
> pointers as to what might be causing this?
>
> I am running on Windows XP. All the example apps work fine.
>
> Many Thanks
>
> --
> To unsubscribe, e-mail:
> <mailto:struts-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
> <mailto:struts-user-help@jakarta.apache.org>
>


--
To unsubscribe, e-mail:   <
mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <
mailto:struts-user-help@jakarta.apache.org>






--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message