struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "olivier" <o...@noos.fr>
Subject RE: Error loading struts-config
Date Fri, 27 Dec 2002 08:13:59 GMT
Hi.
I often have this problem with unmatched closing tags in the struts-config.
for instance :
<property name="blah" value="duh"> instead of <property name="blah"
value="duh" />

But it might be anything else in your struts-config that don't follow the
correct DTD syntax (like declaring actions before forms)

olivier

-----Message d'origine-----
De : Howard Miller [mailto:me@howardmiller.co.uk]
Envoye : lundi 23 decembre 2002 20:03
A : Struts Users Mailing List
Objet : RE: Error loading struts-config


That's what I thought! BUT...

No! The struts-config.xml file is safely in the .war file. A jar -tf
produces.

WEB-INF/lib/xercesImpl.jar
WEB-INF/lib/xmlParserAPIs.jar
WEB-INF/struts-bean.tld
WEB-INF/struts-config.xml
WEB-INF/struts-html.tld
WEB-INF/struts-logic.tld
WEB-INF/struts-nested.tld
WEB-INF/struts-template.tld
WEB-INF/struts-tiles.tld
etc.

So its not that! Its GOT to be something really stupid, but the exception
handling in
that bit of ActionServlet is a bit coarse grained, so I'm left guessing what
the problem
could be.

HM



On 23 Dec 2002 at 9:18, Siggelkow, Bill wrote:

> The error sounds like the servlet cannot even find struts-config.xml.
Check the war to make sure struts-config is really there and in the WEB-INF
folder.  You can open the war with WinZip.  Also, make sure that the folder
WEB-INF is in all caps.
>
> -----Original Message-----
> From: Howard Miller [mailto:me@howardmiller.co.uk]
> Sent: Monday, December 23, 2002 8:59 AM
> To: struts-user@jakarta.apache.org
> Subject: Error loading struts-config
>
>
> Hi,
>
> I am just setting up a new Struts project. I have the Action servlet set
> up and a struts-config.xml with almost nothing in it. When the war is
> installed the servlet starts and then throws this error...
>
> 2002-12-23 13:47:11 StandardContext[/quest]: Servlet /quest threw
> load() exception
> javax.servlet.UnavailableException: Parsing error processing
> resource path /WEB-INF/struts-config.xml
> 	at
> org.apache.struts.action.ActionServlet.initApplicationConfig(ActionS
> ervlet.java:866)
> 	at
> org.apache.struts.action.ActionServlet.init(ActionServlet.java:455)
> ...lots more....
>
> I have no idea what's gone wrong. I seem to get the error regardless
> of what's in the struts-config file or even if I remove it alltogether.
>
> As the error message appears to be no help... has anybody got any
> pointers as to what might be causing this?
>
> I am running on Windows XP. All the example apps work fine.
>
> Many Thanks
>
> --
> To unsubscribe, e-mail:
<mailto:struts-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
<mailto:struts-user-help@jakarta.apache.org>
>
> --
> To unsubscribe, e-mail:
<mailto:struts-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
<mailto:struts-user-help@jakarta.apache.org>
>
>



--
To unsubscribe, e-mail:
<mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:struts-user-help@jakarta.apache.org>



--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message