struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adel <oka_a...@yahoo.com>
Subject Re: problem with bean:define tag
Date Thu, 23 Jan 2003 21:05:15 GMT

Hi again,
Thanks for your answer David. The beanName I am using is Action.Mapping_KEY:
<bean:define name="<%=Action.Mapping_KEY%>" id="path" property="path"
scope="request" toScope="page" />
This works fine with 1.1b1 but not with 1.1b3.
Adel
 Note that you will get this message if the count of "name", "value", and
"body" is != 1.  The message sounds like it's saying you have more than
one of them, but in truth you could get the error if you had none of
them.  I'm going to guess that "beanName" is empty or null.

-----Original Message-----
From: Adel [mailto:oka_adel@yahoo.com] 
Sent: Thursday, January 23, 2003 10:31 AM
To: struts-user@jakarta.apache.org
Subject: problem with bean:define tag


Hi,

I am having a strange problem with stuts 1.1.b3 (with Weblogic 7).
Everything woks fine with struts 1.1.b1 but when I moved to the 1.1.b3
the define tag is generating an exception. The define tag that generates
the execption:

<bean:define name="<%=beanName%>" id="path" property="path"
scope="request" toScope="page" />

The generated exception :

javax.servlet.jsp.JspException: Define tag can contain only one of name
attribute, value attribute, or body content

Adel.




---------------------------------
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now


---------------------------------
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message