struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arik Levin ( Tikal )" <ar...@businesslayers.co.il>
Subject RE: html:form action attribute not set correctly
Date Wed, 01 Jan 2003 16:03:47 GMT
Can you add the struts-config.xml mapping? 


-----Original Message-----
From: Eric Jain [mailto:Eric.Jain@isb-sib.ch] 
Sent: Wednesday, January 01, 2003 5:47 PM
To: struts-user
Subject: html:form action attribute not set correctly

I'm having some problems with a form not setting its action attribute as
expected. For example

  <html:form action="/search" method="get">
    ...
  </html:form>

generates

  <form name="search-form" method="get" action="/application">
    ...
  </form>

rather than

  <form name="search-form" method="get" action="/application/search">
    ...
  </form>

or

  <form name="search-form" method="get" action="search">
    ...
  </form>

'/search' is a correctly configured action, if randomly changed to something
else there is a 'cannot retrieve action mapping' message, as expected, and
besides '/application/search' works perfectly if accessed directly.

What am I doing wrong?


--
Eric Jain


--
To unsubscribe, e-mail:
<mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:struts-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:struts-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:struts-user-help@jakarta.apache.org>


Mime
View raw message