struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sandhya Sasidharan" <sandhya.sasidha...@wipro.com>
Subject RE: findForward() goes to a blank page!!
Date Tue, 18 Feb 2003 15:48:23 GMT
Thanks for your reply Tim....

I figured the problem as u mentioned in the changewelmsg.do action class
itself...i had not mapped "displayMain" in this action class :)
Works fine now!!


-----Original Message-----
From: Chen, Gin [mailto:Gin.Chen@NielsenMedia.com] 
Sent: Tuesday, February 18, 2003 9:02 PM
To: 'Struts Users Mailing List'
Subject: RE: findForward() goes to a blank page!!


Are you sure its not the displayMain action that is not showing
anything? From a brief glance, it looks like your code forwards okay.
What does ur changewelmsg.do action do? -Tim

-----Original Message-----
From: Sandhya Sasidharan [mailto:sandhya.sasidharan@wipro.com]
Sent: Tuesday, February 18, 2003 10:29 AM
To: Struts Users Mailing List
Cc: Sandhya Sasidharan
Subject: findForward() goes to a blank page!!


Hi everyone,
 
I have a problem with returning to the previous page using
findForward(). In my Action class, depending on the action which has to
be performed, I am forwarding it to a certain jsp. The code looks like
this....
 
    else if(strAction.equals("cancel")) {
     ((ChangeWelForm) form).setTheMessage(strMsgPrev);
    return mapping.findForward("displayMain");
 
I have set ("displayMain") in my struts-config file :
 
    <action    path="/changewelprev"
               type="com.dweb.action.ChangeWelPrevAction"
               name="ChangeWelForm"
               scope="request" 
               input="/jsp/admin/admChangeWelPrev.jsp">
        <forward name="displayMain"   path="/changewelmsg.do" />
    </action> 
 
But i get a blank page on performing this action!!
Can anyone please let me know if i'm missing something here since i'm
new to struts!!
 
Thanks & Regds
Sandhya
 


Mime
View raw message