struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Chow" <ec...@macaucabletv.com>
Subject Struts-Tiles causes charset problem!!!
Date Thu, 06 Mar 2003 10:40:48 GMT
Hi,

I want to display some Chinese in JSP(Customer Tag).

If my JSP as following: (showChineseContent.jsp)
=======================================
<%@ page language="java" contentType="text/html" %>
<%@ taglib uri="/WEB-INF/tld/test.tld" prefix="test" %>
<%@ taglib uri="/WEB-INF/tld/share.tld" prefix="share" %>

<html>
<head>
 <meta http-equiv="content-type" content="text/html; charset=UTF-8"> 
 <meta HTTP-EQUIV="Pragma" CONTENT="no-cache">
 <title>Chinese Form</title>
 
 <link rel="stylesheet" href="css/myapp.css">
</head>
<body>


<table border=0 width=100% align=center cellspacing=2 cellpadding=2>
 <test:chineseFormList>
 <tr>
  <th>ID</th>
  <th>Name</th>
 </tr>
 
 <share:list>
 <tr>
  <td><test:chineseFormInfo property="messageID"/></td>
  <td><test:chineseFormInfo property="name"/></td>
 </tr> 
 </share:list>
 
 </test:chineseFormList>
</table>
</body>
</html>


The above JSP works very well, I can retrieve those Chinese from database and display them
correctly.


After I change it to use Tiles as a template as following:

tiles-def.xml
=========
<definition name="showChineseLayout" path="template.jsp">
  <put name="title"  value="Test Chinese" />
  <put name="content" value="showChineseContent.jsp" />
 </definition>


in my showChinese.jsp
===================
<tiles:insert definition="showChineseLayout" flush="true" />




After changed to tiles, everything is wrong, all the Chinese displayed as some QUESTION-MARKS
!!!!!!!!!


Is there any problem in Tiles?  And, I tried to use <jsp:include page="showChineseContent.jsp"
flush="true"/> instead of Tiles, it also not worked.

Any idea on it?



Best regards,
Eric

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message