struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard Raquepo" <rraqu...@primeorion.com>
Subject Re: problem in struts
Date Wed, 12 Mar 2003 08:51:12 GMT
it is... i put a code on my service class that populates the bean and it did
have a data.

one thing i've noticed is my mapping.getAttribute() is null.

part of my struts-config.xml is:
   <action path="/EditTmAccount"
    type="com.fltic.crm.action.manager.EditTmAccountAction">
    name="userAccountForm"
    scope="session"
    validate="false">
    <set-property property="loginRequired" value="true"/>
    <forward name="success" path="/manager/edittm.jsp"/>
   </action>
   <action path="/SaveEditedTmAccount"
    type="com.fltic.crm.action.ManagerAction"
    name="userAccountForm"
    scope="session"
    input="/EditTmAccount.do"
    validate="true">
    <set-property property="loginRequired" value="true"/>
    <forward name="success" path="/manager/edittm.jsp"/>
    <forward name="error" path="/EditTmAccount.do"/>
   </action>
--->
so normally putting the bean in the session
    session.setAttribute(mapping.getAttribute(), form);
will not work but when i manually put
    session.setAttribute("userAccountForm", form);
the fields are displayed/populated in my jsp form.

i don't want to put manually the name of the form. that should be automatic
form the struts-config.xml. any reason why?

thanks
----- Original Message -----
From: "Kwok Peng Tuck" <pengtuck@makmal.net>
To: "Struts Users Mailing List" <struts-user@jakarta.apache.org>
Sent: Wednesday, March 12, 2003 4:43 PM
Subject: Re: problem in struts


> Looks like your form bean is not initialized ..
>
> Richard Raquepo wrote:
>
> >no error just empty fields...
> >
> >----- Original Message -----
> >From: "Kwok Peng Tuck" <pengtuck@makmal.net>
> >To: "Struts Users Mailing List" <struts-user@jakarta.apache.org>
> >Sent: Wednesday, March 12, 2003 4:30 PM
> >Subject: Re: problem in struts
> >
> >
> >
> >
> >>Do you get a specific error on the page when you try to display the
> >>contents of the form bean ? Or just no error, empty fields ?
> >>
> >>
> >>---------------------------------------------------------------------
> >>To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
> >>For additional commands, e-mail: struts-user-help@jakarta.apache.org
> >>
> >>
> >>
> >>
> >
> >
> >---------------------------------------------------------------------
> >To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
> >For additional commands, e-mail: struts-user-help@jakarta.apache.org
> >
> >
> >
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: struts-user-help@jakarta.apache.org
>
>



---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org


Mime
View raw message