struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Feller" <Emmanuel.Fel...@free.fr>
Subject Re: Which J2EE version is compliant with Struts apps?
Date Thu, 06 Mar 2003 17:13:08 GMT
Hi,

You can compile against J2EE 1.3.
(It contain servlet2.3 API and it is supported by struts.)

You may use J2EE 1.2 but it is not the best environnement on
was5. I'd prefer 1.3 if i had to do the choice.

I hope it helps,

Regards,
Emmanuel Feller
Senior Developper
Cap Gemini Ernst & Young
+33 2 51 17 35 00 phone 3716
+33 6 23 34 63 39
----- Message d'origine -----
De : "Adolfo Miguelez" <pelly69@hotmail.com>
À : <struts-user@jakarta.apache.org>
Envoyé : jeudi 6 mars 2003 18:07
Objet : Re: Which J2EE version is compliant with Struts
apps?


> When deployed to a server container as WAS, or even WSAD
making de WAR (EAR)
> file, it ask you which J2EE version you want to use for
the deployment.
>
> So far we have used J2EE 1.2, since we were using WAS 3.5
and it was the
> only chance.
>
> Now, updating to WAS 5 it is possible choose among J2EE
1.2 and J2EE 1.3,
> and I was wondering if would be any compatibility issues
with Struts, or
> even problems with backwards compatibility with our
previous deployed apps
> adopting J2EE 1.3 for deployments.
>
> Adolfo
>
>
>
>
>
>
>
>
> >From: "David Graham" <dgraham1980@hotmail.com>
> >Reply-To: "Struts Users Mailing List"
<struts-user@jakarta.apache.org>
> >To: struts-user@jakarta.apache.org
> >Subject: Re: Which J2EE version is compliant with Struts
apps?
> >Date: Thu, 06 Mar 2003 08:46:07 -0700
> >
> >Yes, but I don't know why you would choose 2.2 when 2.3
is newer and more
> >powerful.
> >
> >David
> >
> >
> >
> >>From: "Adolfo Miguelez" <pelly69@hotmail.com>
> >>Reply-To: "Struts Users Mailing List"
<struts-user@jakarta.apache.org>
> >>To: struts-user@jakarta.apache.org
> >>Subject: Re: Which J2EE version is compliant with Struts
apps?
> >>Date: Thu, 06 Mar 2003 15:33:06 +0000
> >>
> >>So, then we can choose among J2EE 1.2 (servlets 2.2) and
J2EE 1.3
> >>(servlets 2.3). Is not it?
> >>
> >>>From: "David Graham" <dgraham1980@hotmail.com>
> >>>Reply-To: "Struts Users Mailing List"
<struts-user@jakarta.apache.org>
> >>>To: struts-user@jakarta.apache.org
> >>>Subject: Re: Which J2EE version is compliant with
Struts apps?
> >>>Date: Thu, 06 Mar 2003 08:13:50 -0700
> >>>
> >>>You can use Struts in servlet 2.2 or 2.3 environments.
> >>>
> >>>David
> >>>
> >>>
> >>>
> >>>>From: "Adolfo Miguelez" <pelly69@hotmail.com>
> >>>>Reply-To: "Struts Users Mailing List"
<struts-user@jakarta.apache.org>
> >>>>To: struts-user@jakarta.apache.org
> >>>>Subject: Which J2EE version is compliant with Struts
apps?
> >>>>Date: Thu, 06 Mar 2003 10:07:32 +0000
> >>>>
> >>>>Hi All,
> >>>>
> >>>>an easy question. AFAIK, Struts is based on servlets
2.2 and JSP 1.1
> >>>>specs. Therefore a J2EE 1.2 compliant app server is
needed. Right?
> >>>>
> >>>>We are investigating about using WAS5 and WSAD5. Both
of them actually
> >>>>permit to choose among developing or deploying J2EE1.2
or J2EE1.3
> >>>>compliant applications.
> >>>>
> >>>>The question is:
> >>>>
> >>>>could we deploy Struts apps as J2EE 1.3 compliant apps
and therefore
> >>>>standing on Servlets 2.3 and JSP 1.2 specs. I guess
that should be
> >>>>backwards compatibility in new specs so should be no
problem, but I
> >>>>would appreciate confirmation. Any expected
compatibility mismatch?
> >>>>
> >>>>What J2EE specs Struts deployers match for your Struts
apps? What are
> >>>>the choices? (I suppose no difference among Struts
1.0.2 and Struts 1.1,
> >>>>since both are servlets 2.2 and JSP 1.1 compliants).
> >>>>
> >>>>Thanks in advance,
> >>>>
> >>>>Adolfo.
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>
>
>>>>________________________________________________________
_________
> >>>>MSN 8 helps eliminate e-mail viruses. Get 2 months
FREE*.
> >>>>http://join.msn.com/?page=features/virus
> >>>>
> >>>>
>
>>>>--------------------------------------------------------
-------------
> >>>>To unsubscribe, e-mail:
struts-user-unsubscribe@jakarta.apache.org
> >>>>For additional commands, e-mail:
struts-user-help@jakarta.apache.org
> >>>
> >>>
>
>>>_________________________________________________________
________
> >>>STOP MORE SPAM with the new MSN 8 and get 2 months
FREE*
> >>>http://join.msn.com/?page=features/junkmail
> >>>
> >>>
>
>>>---------------------------------------------------------
------------
> >>>To unsubscribe, e-mail:
struts-user-unsubscribe@jakarta.apache.org
> >>>For additional commands, e-mail:
struts-user-help@jakarta.apache.org
> >>>
> >>
> >>
>
>>__________________________________________________________
_______
> >>The new MSN 8: smart spam protection and 2 months FREE*
> >>http://join.msn.com/?page=features/junkmail
> >>
> >>
>
>>----------------------------------------------------------
-----------
> >>To unsubscribe, e-mail:
struts-user-unsubscribe@jakarta.apache.org
> >>For additional commands, e-mail:
struts-user-help@jakarta.apache.org
> >
> >
>
>___________________________________________________________
______
> >MSN 8 helps eliminate e-mail viruses. Get 2 months FREE*.
> >http://join.msn.com/?page=features/virus
> >
> >
>
>-----------------------------------------------------------
----------
> >To unsubscribe, e-mail:
struts-user-unsubscribe@jakarta.apache.org
> >For additional commands, e-mail:
struts-user-help@jakarta.apache.org
> >
>
>
>
____________________________________________________________
_____
> Help STOP SPAM with the new MSN 8 and get 2 months FREE*
> http://join.msn.com/?page=features/junkmail
>
>
> ----------------------------------------------------------
-----------
> To unsubscribe, e-mail:
struts-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail:
struts-user-help@jakarta.apache.org
>
>



---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org


Mime
View raw message