struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ashish Kulkarni <kulkarni_ash1...@yahoo.com>
Subject Re: Problem with locale
Date Tue, 25 Mar 2003 20:01:10 GMT
Hi,
try putting locale in the session of the user,
Locale l=new Locale("es","ES");
session.setAttribute(Globals.LOCALE_KEY , l);

Ashish
--- Miguel Angel Medina Lopez
<mamedina@logic-factory.com> wrote:
> Hi all:
> 
> I have a problem when I want to change the locale of
> my struts application. By defauly, when I get the
> Locale, with the next code:
> 
> log.debug("The locale is "+locale.toString());
> 
> the result is  "The locale is en_US". Now I want to
> change the locale to spanish with the code:
> 
> Locale l=new Locale("es","ES");
> setLocale(request,l);
> 
> and the out from the logger is "The locale is
> es_ES", however, in the JSPs, the output take the
> messages from the english (_en) resource bundle. The
> default resource is in spanish. 
> 
> Any suggestion? Thank you in advance.
> 
>
-------------------------------------------------------------
> Miguel Ángel Medina López
> Logic Factory: www.logic-factory.com
> Granada - España
> 
> 
> 


__________________________________________________
Do you Yahoo!?
Yahoo! Platinum - Watch CBS' NCAA March Madness, live on your desktop!
http://platinum.yahoo.com

---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org


Mime
View raw message