struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Kyser <ktra...@comcast.net>
Subject Re: Html:button tag problem
Date Fri, 28 Mar 2003 03:30:30 GMT
Looks like you have an extra tic in your first line:

	'<%reportName'%>',
                                      ^
was that just a typo in the e-mail?

-jeff

On Thursday, March 27, 2003, at 09:23  PM, LouD0966@aol.com wrote:

> Hello,
>
> I am converting an app to Struts.
>
> In the original JSP page, I had
> <% ...
> String reportName = (String) 
> session.getAttribute(Parameter.REPORT_NAME);
> ...
> %>
> ...
> <BODY
> ...
> <input type="button" name="showReport" value="Submit"
>     onclick="performSubmit('<%=reportName'%>','SUBMIT_BUTTON')">
>
> In the new code, the <input> tag is now:
> <html:button property="showReport" value="Submit"
>     onclick="performSubmit('<%=reportName%>','SUBMIT_BUTTON')">
>
> However, when I run this, the <%=reportName%> does not resolve to it's 
> value.
> When I View Source (using Netscape), I see the ">','SUBMIT_BUTTON')" 
> part of
> the onclick blinking.
>
> I also tried
> <c:set var="onclick" scope="page">
>   performSubmit( '<%=reportName%>', 'SUBMIT_BUTTON')
> </c:set>
>
> <html:button property="showReport" value="Submit" 
> onclick="${onclick}"/>
> but it didn't resolve ${onclick} .
>
> Any ideas would be greatly appreciated.
>
> Thanks.
>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org


Mime
View raw message