struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alonso, Damian" <Damian.Alo...@sensis.com.au>
Subject <html:errors/> not showing anything!
Date Tue, 25 Mar 2003 22:35:41 GMT

I currently have a Struts 1.1 application that I am currently moving to use
frames and tiles.  I am still not sure if my <html:errors/> is not working
because I am using frames, or because it is not reading the
application.properties.  This is where I need your help! :-)

 

When I expect an error, I was getting the expected error on my form page.
As read in other posts, I wanted to check if my errors where actually
getting processed, so in my struts-config.xml file, I added the following to
my message-resources definition.

 

<message-resources parameter="resources.application" null="false"/>

 

After putting the null="false", I was able to get my Error Key to appear in
the page but it didn't translate to the message I have in my
application.properties file.

 

This is what I now see:

 

???en_US.ALL_FIELDS_NULL???

 

Any ideas on why I cannot see my error messages??

 

Thanks in advance,

 

Damian.

 


www.sensis.com.au

A leading Australian advertising, information 
and directories business. 

www.yellowpages.com.au
www.whitepages.com.au
www.citysearch.com.au
www.whereis.com.au
www.telstra.com.au

This email and any attachments are intended only for the use of the recipient and may be confidential
and/or legally privileged.
Sensis Pty Ltd disclaims liability for any errors, omissions, viruses, loss and/or damage
arising from using, opening or transmitting this email.
If you are not the intended recipient you must not use, interfere with, disclose, copy or
retain this email and you should notify the sender immediately by return email or by contacting
Sensis Pty Ltd by telephone on [+61 3 9201 4888]

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message