struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Santos" <mister...@hotmail.com>
Subject Re: deprecation error moving from Tomcat 4.0.4 to 4.1.18?
Date Wed, 26 Mar 2003 04:12:30 GMT
OK, to me it seems to be something related to Tomcat. Try using <jsp:include
page="<%= includePage.toString() %>" flush="true" /> instead.

[]s
--
Michael Nascimento Santos
Sun Certified Programmer for the Java 2 Platform
Sun Certified Programmer for the Java 2 Platform 1.4
Sun Certified Web Component Developer for J2EE
Moderador SouJava - www.soujava.org.br

----- Original Message -----
From: "Oliver Meyn" <lists@mineallmeyn.com>
To: "STRUTS" <struts-user@jakarta.apache.org>
Sent: Tuesday, March 25, 2003 6:33 PM
Subject: deprecation error moving from Tomcat 4.0.4 to 4.1.18?


> Hi all,
>
> Code that has worked fine under Struts 1.1 rc1 in Tomcat 4.0.4 is now
> failing in 4.1.18 (j2sdk1.4.1_02).  Other servlets made the switch ok, but
> when I try to <jsp:include page="<%= a bean value %>" /> the page fails
with
> a somewhat cryptic error as below:
>
> [ERROR]
> org.apache.jasper.JasperException: Unable to compile class for JSP
>
> An error occurred at line: 39 in the jsp file: /data/statistics.jsp
>
> Generated servlet error:
>     [javac] Compiling 1 source file
>
> C:\jakarta-tomcat-4.1.18\<removed>\data\statistics_jsp.java:136:
>
include(javax.servlet.http.HttpServletRequest,javax.servlet.http.HttpServlet
> Response,java.lang.String,javax.servlet.jsp.JspWriter,boolean) in
> org.apache.jasper.runtime.JspRuntimeLibrary cannot be applied to
>
(javax.servlet.http.HttpServletRequest,javax.servlet.http.HttpServletRespons
> e,java.lang.Object,javax.servlet.jsp.JspWriter,boolean)
>           JspRuntimeLibrary.include(request, response,  includePage , out,
> true);
>                            ^
> An error occurred at line: 39 in the jsp file: /data/statistics.jsp
> Generated servlet error:
> Note: C:\jakarta-tomcat-4.1.18\<removed>\data\statistics_jsp.java uses or
> overrides a deprecated API.
> Note: Recompile with -deprecation for details.
> 1 error
> [/ERROR]
>
> This is the code that generates it:
> [CODE]
> <logic:present name="statsNavBean">
> <bean:define id="includePage" name="statsNavBean" property="bodyPage" />
> <jsp:include page="<%= includePage %>" flush="true" />
> </logic:present>
> [/CODE]
>
> The bean:define line is #39 referenced in the error, but I think it must
be
> miscounting since if I remove the jsp:include line it works fine (well,
> compiles fine).
>
> Any ideas on what's causing this?  Is there a newer version of some spec I
> should be writing to for 4.1.18 as opposed to 4.0.4?
>
> I know the includePage is coming back correctly because just printing it
out
> shows that it is correct.  One of the possibilities for includePage is a
> trivial Coming Soon page, and if I define some variable foo =
> "comingsoon.jsp" (same as passed back) and place it in the include instead
> of includePage, it _works fine_.  This must be something in the
interaction
> of the bean and the include, but I can't figure it out.
>
> Hoping it's something obvious,
> Oliver
>
> ps same error on Linux/Apache
>
> ********************
> Oliver Meyn
> oliver@mineallmeyn.com
> "Things should be made as simple as possible, but no simpler." - Albert
> Einstein
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: struts-user-help@jakarta.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org


Mime
View raw message