struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eivind Waaler <eivi...@tihlde.org>
Subject struts-el - weblogic
Date Wed, 19 Mar 2003 10:19:01 GMT
I'm having some problems deploying the strutsel-exercise-taglib.war in my
weblogic 7.0 server. WLS 7.0 is supposed to support jsp 1.2 and servlet
2.3, still i get the following error when trying to access the first
index.jsp page:

<19.mar.03 10:38:29 CET> <Error> <HTTP> <101020>
<[ServletContext(id=570106,name=strutsel-exercise-taglib,context-path=/strutsel-exercise-taglib)]
Servlet failed with Exception
weblogic.servlet.jsp.JspException: (line 3): Error in using tag library
uri='/WEB-INF/struts-html-el.tld' prefix='html-el': The Tag class
'org.apache.strutsel.taglib.html.ELImgTag' has no setter method
corresponding to TLD declared attribute 'onkeypress', (JSP 1.1 spec,
5.4.1)
        at
weblogic.servlet.jsp.StandardTagLib.tld_jspException(StandardTagLib.java:1094)
        at
weblogic.servlet.jsp.StandardTagLib.parseTagDD(StandardTagLib.java:1221)
        at
weblogic.servlet.jsp.StandardTagLib.parseDD(StandardTagLib.java:1119)
        at
weblogic.servlet.jsp.StandardTagLib.<init>(StandardTagLib.java:219)
        at weblogic.servlet.jsp.JspLexer.loadTagLib(JspLexer.java:154)
        at
weblogic.servlet.jsp.JspLexer.mTAGLIB_DIRECTIVE_BODY(JspLexer.java:5123)

Anyone else experienced this? I saw some report about struts-el working on
weblogic 6.1. Any known workaround to get it running?

regards
.eivind w.


---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org


Mime
View raw message