struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Bowen" <robert.bo...@mubimedia.com>
Subject Re-post : Problem with character sets doing struts include. Accented characters getting garbled!!
Date Tue, 11 Mar 2003 18:05:07 GMT
Hello all.

Has anyone ever had a problem maintaining character set in an included page?
I do!

I've tried everything:

1. using jsp format -- <jsp:include/> instead of Struts format, and nothing
works.

2. jsp include of struts action -- <jsp:include page="/do/LoadNoticias...">

3. RequestDispatcher:

<bean:struts id="forwardHomeNoticias" forward="Home_Noticias" />

RequestDispatcher dispatcher =
request.getRequestDispatcher(forwardHomeNoticias.getPath());

dispatcher.include(request, response);

. nothing works!

In my "mother" page I have the meta tag:

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

In the included page I have the page directive:

<%@ page language="java" contentType="text/html; charset=iso-8859-1" %>

But ALL content in the included page -- data from the database, static html,
everything -- appears with question marks instead of accented characters.

If I include a static jsp with accented characters it appears correctly.

My struts calls are:

<bean:include forward="Home_Noticias" id="homeNoticias" /> //struts action,
/do/LoadNoticias/...

<bean:write name="homeNoticias" scope="page" filter="false" /> //print
content

. and no matter what I do it won't print correctly.

Anyone know what the heck else I can try?

Thanks in advance,

Bob




---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org


Mime
View raw message