struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marius Scurtescu <mari...@lightspeed.ca>
Subject Re: Error in Tiles Tutorial?
Date Wed, 25 Jun 2003 17:32:11 GMT
The problem is still there in RC2, it would be really nice if this
toturial makes it into the final release. I posted a bug on this
regard: 21090

Thanks for the link to the old tutorial Cedric. Is there a newer
one? If yes, is there any way to read/get that tutorial?

Marius

Cedric Dumoulin wrote:
> 
>  This error means that the definition "mainLayout" doesn't exist in the 
> tile factory associated to the current module.
>  Apparently, this link doesn't work anymore in the 
> tiles-documentation.war :-(.
>  The (old) tutorial can still be found there 
> http://www.lifl.fr/~dumoulin/tiles/doc/tutorialBody.html
> 
>     Cedric
> 
> K.C. Baltz wrote:
> 
>> I tried to run through the Tiles tutorial this morning and ran into a 
>> problem right off the bat.  I have Struts 1.1 RC1 and have deployed 
>> tiles-documentation.war into Tomcat 4.1.   I can view most of the 
>> documentation, but when I click on the Tutorial link 
>> (http://localhost:8080/tiles-documentation/doc/tutorial.jsp), I get 
>> the following exception:
>> org.apache.jasper.JasperException: Error - Tag Insert : Can't get 
>> definition 'mainLayout'. Check if this name exist in definitions factory.
>>
>> Everything in the configuration looks OK to me at first blush, but if 
>> I really knew how to track down a problem like this, I wouldn't need 
>> the tutorial, would I?  :)
>>
>> I've tried redeploying the WAR with no success.    Does the tutorial 
>> work for anyone else?
>>
>> K.C.
>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
>> For additional commands, e-mail: struts-user-help@jakarta.apache.org
>>
>>



---------------------------------------------------------------------
To unsubscribe, e-mail: struts-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: struts-user-help@jakarta.apache.org


Mime
View raw message